Opened 11 years ago

Closed 11 years ago

#429 closed defect (fixed)

Joined Features are only partially rendered

Reported by: jng Owned by: brucedechant
Priority: high Milestone: 2.0
Component: General Version: 2.0.0
Severity: blocker Keywords: feature join render
Cc: External ID:

Description

Recreating the steps in #413, I am able to now actually see the joined features, except that I only get a few of the expected features.

Attachments (5)

ParcelsJoin1.jpg (156.8 KB) - added by jng 11 years ago.
Expected Joined Layer Preview Result
ParcelsJoin2.jpg (158.4 KB) - added by jng 11 years ago.
Expected Map Preview Result
MyParcelsJoin1.jpg (281.7 KB) - added by jng 11 years ago.
The layer preview I am getting
MyParcelsJoin2.jpg (206.8 KB) - added by jng 11 years ago.
The map preview I am getting
MyJoinSettings.jpg (289.9 KB) - added by jng 11 years ago.
Join settings used for the layer

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by jng

Attachment: ParcelsJoin1.jpg added

Expected Joined Layer Preview Result

Changed 11 years ago by jng

Attachment: ParcelsJoin2.jpg added

Expected Map Preview Result

Changed 11 years ago by jng

Attachment: MyParcelsJoin1.jpg added

The layer preview I am getting

Changed 11 years ago by jng

Attachment: MyParcelsJoin2.jpg added

The map preview I am getting

Changed 11 years ago by jng

Attachment: MyJoinSettings.jpg added

Join settings used for the layer

comment:1 Changed 11 years ago by brucedechant

Owner: set to brucedechant
Status: newassigned

I was able to replicate this issue.

It relates to the batch size being used when doing a join.

comment:2 Changed 11 years ago by brucedechant

Just to clarify. I was able to reproduce this by playing with the join batch size.

I have found the root cause of the problem in the ReadNext?() method and I am working on resolving it.

comment:3 Changed 11 years ago by brucedechant

Resolution: fixed
Status: assignedclosed

The problem inside the ReadNext?() method has been fixed.

Note: See TracTickets for help on using tickets.