Opened 13 years ago

Closed 12 years ago

Last modified 11 years ago

#978 closed bug (fixed)

topological editing with snapping to segment yields 2 vertices instead of 1 adding vertex

Reported by: msieczka Owned by: timlinux
Priority: critical: causes crash or data corruption Milestone:
Component: Digitising Version: Trunk
Keywords: Cc: lami@…
Must Fix for Release: Yes Platform: All
Platform Version: Awaiting user input: no

Description

  1. Add a line or polygon Shapefile or PostGIS layer.
  1. In project properties enable topological editing, set snapping mode "to segment" or "to vertex and segment".
  1. Digitize a line or boundary.
  1. Add a vertex on it, move it - you see 2 vertices were added instead of 1. Topology broken.

SVN r8190.

Attachments (5)

linie_utm33.zip (918 bytes) - added by msieczka 12 years ago.
sample line shapefile
1_before.png (4.2 KB) - added by msieczka 12 years ago.
screendump 1
2_vertex_added.png (6.0 KB) - added by msieczka 12 years ago.
screendump 2
3_vertex_moved.png (6.0 KB) - added by msieczka 12 years ago.
screendump 3
4_vertex_moved2.png (6.1 KB) - added by msieczka 12 years ago.
screendump 4

Download all attachments as: .zip

Change History (16)

comment:1 Changed 13 years ago by leolami

Cc: lami@… added

comment:2 Changed 12 years ago by msieczka

Still valid as of r8352.

comment:3 Changed 12 years ago by timlinux

Milestone: Version 1.0Version 0.11.0
Owner: changed from nobody to timlinux
Status: newassigned

comment:4 Changed 12 years ago by timlinux

Resolution: worksforme
Status: assignedclosed

Cant replicate. I created a new line using the 'lines' layer in tests/testdata. Digitised a line across one of the roads with a vertex snapped to the road I was crossing. When I subsequently move the vertex, 4 red guides appear and both features are modified in shape as I drag the vertex around.

I'm marking this as 'works for me'. Please advise with more detail if there is something I'm missing and we can adjust the status of the ticket accordingly.

Regards

Tim

comment:5 Changed 12 years ago by msieczka

Resolution: worksforme
Status: closedreopened

Tim

You need to set snapping different than 0 for the given layer to notice the bug.

The greater snapping threshold, the greater chance of reproducing the error - at 10 I have 100% "success" of adding 3 vertices instead of 1 in a line Shapefile layer.

Please please fix it before release.

comment:6 Changed 12 years ago by timlinux

Hi

Ah ok - I had tested at 1 and at 0.1 and it was working ok - will retest.

Regards

Tim

comment:7 Changed 12 years ago by timlinux

I still cant replicate this issue. Could you send me a small dataset to test with that will allow me to replicate?

If I cant replicate and resolve this tomorrow I am going to push this bug over to 1.0.0 milestone.

Regards

Tim

comment:8 Changed 12 years ago by msieczka

Tim,

I can still reproduce the bug in latest trunk r8750. Follow this please:

  1. Open the attached shapefile in QGIS.
  1. Project properties: check "Enable topological editing".
  1. Project properties > Snapping options: check the layer, Mode: "to vertex and segment", Tolerance: "10".
  1. Toggle editing.
  1. Add a vertex, move it - you'll see 3 vertices were added instead of 1. The attached screendumps show that it really happens.

Changed 12 years ago by msieczka

Attachment: linie_utm33.zip added

sample line shapefile

Changed 12 years ago by msieczka

Attachment: 1_before.png added

screendump 1

Changed 12 years ago by msieczka

Attachment: 2_vertex_added.png added

screendump 2

Changed 12 years ago by msieczka

Attachment: 3_vertex_moved.png added

screendump 3

Changed 12 years ago by msieczka

Attachment: 4_vertex_moved2.png added

screendump 4

comment:9 Changed 12 years ago by timlinux

Hi

Ah great thanks for that I can replicate the issue now.

Regards

Tim

comment:10 Changed 12 years ago by mhugent

Resolution: fixed
Status: reopenedclosed

This should be fixed in r8753. Please test and reopen the bug if you still have the problem

comment:11 Changed 11 years ago by (none)

Milestone: Version 0.11.0

Milestone Version 0.11.0 deleted

Note: See TracTickets for help on using tickets.