Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#979 closed defect (fixed)

disable "move vertex" tool editing points layer

Reported by: msieczka Owned by: jef
Priority: major: does not work as expected Milestone:
Component: Digitising Version: Trunk
Keywords: Cc:
Must Fix for Release: Yes Platform: All
Platform Version: Awaiting user input: no

Description

As the title reads. The "move feature" tool is enough for points. Having 2 tools doing the same confuses the user.

Change History (9)

comment:1 Changed 12 years ago by msieczka

Still valid as of r8352.

comment:2 Changed 12 years ago by jef

Owner: changed from nobody to jef

comment:3 Changed 12 years ago by mhugent

Resolution: fixed
Status: newclosed

fixed in r8363

comment:4 Changed 12 years ago by msieczka

Resolution: fixed
Status: closedreopened

I just tried with an empty PostGIS multipoint layer and both tools are still active in digitizer. If there is at least one point it's OK though.

What's wrong?

comment:5 Changed 12 years ago by mhugent

Resolution: fixed
Status: reopenedclosed

This is intended behaviour. The tool is only disabled for point layers. It is enabled for multipoint layers to allow for the possibility to move only one point of a multipoint feature.

comment:6 Changed 12 years ago by msieczka

Ah, well thought.

However, I can see that both tools are enabled for simple point layers as well. Does it have to?

Also, the "Move vertex" remains selectable even after I quit digitizer.

comment:7 Changed 12 years ago by mhugent

Oh, you are right, there is still a bug. Please try if it works now in r8371.

comment:8 Changed 12 years ago by msieczka

All OK now!

comment:9 Changed 11 years ago by (none)

Milestone: Version 0.9.2

Milestone Version 0.9.2 deleted

Note: See TracTickets for help on using tickets.