Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#3124 closed enhancement (fixed)

Add 'Apply' button to the layer's query function

Reported by: jrm Owned by: nobody
Priority: minor: annoyance Milestone: Version 1.6.0
Component: GUI Version:
Keywords: Cc:
Must Fix for Release: No Platform: All
Platform Version: Awaiting user input: no

Description

The use of the layer's 'Query' function is difficult when used frequently : if you make a query than choose to modify it you have to open the query window, erase the existing query, close the window, reopen the window, type the new query then close the window again.

It requires 6 steps to update the query if the new parameter concerns data previously left out, if the user doesn't follow them the query tool will notify him that there is no data corresponding to his request due to the limited subset being actually used.

A solution would be to offer an 'Apply' button which would applied the query on the source data, discarding any previous queried subset, without leaving the query window.

Change History (4)

comment:1 Changed 9 years ago by jef

Resolution: fixed
Status: newclosed

With r14386 is now left in the last successfully tested state.

comment:2 Changed 9 years ago by jrm

Resolution: fixed
Status: closedreopened

Hi Jef,

sorry I've not been clear, the problem is that if you want to extend your query beyond an existing queried subset, you have to open/close/open/close the window.

ex for a table with 3 names george/bill/bob :

  1. query "name" = 'george'
  2. query "name" = 'george' OR "name" = 'bill', it will return a message saying that there no feature 'bill' because the subset created by the first query left them out
  3. erase the query
  4. close the window (OK)
  5. open the window, write the 2nd query
  6. close the window

it would be easier with an 'Apply' button similar to the one used to apply symbology changes, getting the same result with half the click

comment:3 in reply to:  2 ; Changed 9 years ago by jef

Resolution: fixed
Status: reopenedclosed

Replying to jrm:

sorry I've not been clear, the problem is that if you want to extend your query beyond an existing queried subset, you have to open/close/open/close the window.

Sorry, I wasn't able to reproduce that problem. The only problem there was, was that the sample button used the original query, so to see values that were excluded by the earlier query, you needed to clear, close and reopen. Now it's works on the last successfully tested query, so you can "test" and retrieve the values of the current query.

Other than that the query isn't incremental. The subset string is fully replaced, with the one you enter.

ex for a table with 3 names george/bill/bob :

  1. query "name" = 'george'
  2. query "name" = 'george' OR "name" = 'bill', it will return a message saying that there no feature 'bill' because the subset created by the first query left them out

Huh? that doesn't make any sense. The subset string either gets you results or it doesn't. It most certainly wouldn't complain about false operands of OR, even if the query was incremental.

If it was somehow related to the previous query, you still just wouldn't see Bills, but that's not the case. If you query for Georges, you get Georges. If you query for Bills, you get Bills. If you query for Bills or Georges, you get Bills and Georges. If you query for Bills and Georges, you get nothing. The order of queries doesn't matter and you don't need to clear the query in between.

BTW just to be sure I created a point shapes with Bills and Georges and verified the above.

comment:4 in reply to:  3 Changed 9 years ago by jrm

Replying to jef:

Sorry, I wasn't able to reproduce that problem. The only problem there was, was that the sample button used the original query, so to see values that were excluded by the earlier query, you needed to clear, close and reopen. Now it's works on the last successfully tested query, so you can "test" and retrieve the values of the current query.

Thank for the clarification, I tried rv14387 but I did not use the 'test' button to reset the sample because I didn't understood it was its intended function. Maybe this should be the role of 'Clear' ?

Note: See TracTickets for help on using tickets.