Opened 15 years ago

Closed 13 years ago

Last modified 11 years ago

#2 closed enhancement (duplicate)

Save/restore default symbology

Reported by: stevehalasz Owned by: gsherman
Priority: minor: annoyance Milestone:
Component: Project Loading / Saving Version: Trunk
Keywords: layer properties colours colors symbology Cc:
Must Fix for Release: No Platform: All
Platform Version: Awaiting user input: no

Description

I would love to have an option in the symbology preferences to "save as default". This would save the symbology info in a .qgl file for instance. Each provider would implement it differently. When adding the layer again later it would apply the default symbology automatically if it is found.

Change History (7)

comment:1 Changed 15 years ago by gsherman

Milestone: Version 1.0 Release

This is an important feature to have in place by the 1.0 release.

comment:2 Changed 14 years ago by cavallini@…

Platform: Debian
Version: HEAD

this seems the same as #169. Better merge the two?

comment:3 Changed 14 years ago by anonymous

Platform: DebianAll

comment:4 Changed 14 years ago by shalasz

Component: GUIProject Loading / Saving
Keywords: layer properties colours colors symbology added

#169 is a duplicate of this. Paolo says:

It would be very useful to have the possibility of saving layer properties even independently of projects; therefore different users or different projects could share uniform layer colours, transparency etc. GRASS implements a similar mechanism with RGB column in the database (which would be good to be able to reuse in QGIS). This, couples with the possibility of assigning properties to a bunch of layers (like a "catalog") would allow much smoother work.

comment:5 Changed 14 years ago by anonymous

Awaiting user input: unset
Must Fix for Release: No

comment:6 Changed 13 years ago by timlinux

Resolution: duplicate
Status: newclosed

Ticket #840 which I opened recently also duplicates this. I know this is the first report for this, but Im closing this ticket and managing it further from #840.

comment:7 Changed 11 years ago by (none)

Milestone: Version 1.0.0

Milestone Version 1.0.0 deleted

Note: See TracTickets for help on using tickets.