Opened 14 years ago

Closed 12 years ago

#1045 closed bug (fixed)

Renaming layer in legend requires layer name change to cancel it's renaming

Reported by: marisn Owned by:
Priority: major: does not work as expected Milestone: Version 1.2.0
Component: Map Legend Version: Trunk
Keywords: Cc: pcav
Must Fix for Release: Yes Platform: Linux
Platform Version: Awaiting user input: no

Description

In legend right click layer name, choose rename and then try to cancel rename action without actually renaming layer. Only way how to cancel renaming is by changing atleast single letter in layer's name.

QGIS rev. 8351 Qt 4.3.4

Change History (6)

comment:1 Changed 13 years ago by jef

see also #1281

comment:2 in reply to:  1 Changed 13 years ago by msieczka

Component: Build/InstallMap Legend
Must Fix for Release: NoYes
Platform: GentooLinux
Priority: minor: annoyance or enhancementmajor: does not work as expected
Type: defectbug

Replying to jef:

see also #1281

Ah yes. So this means the issue is still actuall as of QT 4.4.0, SVN r9284.

comment:3 Changed 12 years ago by lutra

Cc: pcav added
Milestone: Version 1.0.3Version 1.2.0

Still a issue on QGIS 1.2 (rev. 10988 on Ubuntu 9.04).

comment:4 Changed 12 years ago by lutra

Owner: changed from nobody to wonder

Hi, I just noticed that editing layer names using the "F2" key seems to work fine now

https://trac.osgeo.org/qgis/ticket/1440

you can exit/stop editing names (even if you haven't changed the name at all) by just selecting another layer, pressing enter or esc.

I guess this should help fixing the problem of editing trough

right click -> rename

especially when no changes are made.

PS

try

right click -> rename

a layer, rename it and press "esc" to exit. Qgis 1.2 (rev. 11015, Ubuntu 9.04) crashes (seg fault).

comment:5 Changed 12 years ago by wonder

Owner: wonder deleted

comment:6 Changed 12 years ago by jef

Resolution: fixed
Status: newclosed

fixed in r11022

Note: See TracTickets for help on using tickets.