Opened 9 years ago

Closed 7 years ago

#833 closed task (fixed)

PostGIS 2.0 Testing on various desktops

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 2.0.0
Component: postgis Version: master
Keywords: Cc:

Description (last modified by robe)

Desktops to test - just itemizing issues so far that we need to address before release (either with an FAQ workaround or get the developers of these to revise)

GvSig? -- I know already gvSig 1.10 doesn't work with PostGIS 2.0 -- looks like they are using AsEWKB which I pulled out.

Others to test uDig -

QGIS 1.5 seems to work okay with 2.0

OpenJump? (I have just 1.3.1 need to check newer)-- Ad hoc Query tool works okay but Data Store layer doesn't seems to use obsolete Extent

pgRouting -- I think this will have issues too as last version I checked was I think using deprecated startpoint and endpoint functions among other things.

Change History (19)

comment:1 Changed 9 years ago by robe

On closer inspection -- QGIS has issues too. QGIS Info tool doesn't work because it uses

AsBinary?, intersects, and setsrid

comment:2 Changed 9 years ago by nicklas

In QGIS this is solved in QGIS trunk (QGIS 1.7). They have nightly builds that I use. But quite annoying is that nightly build id built against Gdal 1.6.x but QGIS 1.6 is built against 1.7.x for Ubuntu. Have not successed to use the raster plugin with any of the versions. load raster to db works, but I have not been able to view the data in QGIS.

For gvSig there is also some trouble in 1.10 not passing the z-values. I had a patch from the developers to try 3D-extension. After some help from them I had it working. About ST_Asbinary I don't know if this was before AsBinary? was removed or if it was fixed in that patch. The z-issue should hopefully be fixes in release 1.11. I also had some troubles with connections hanging after I had removed the table from gvSig.

/Nicklas

comment:3 in reply to:  1 Changed 9 years ago by jef

Replying to robe:

On closer inspection -- QGIS has issues too. QGIS Info tool doesn't work because it uses

AsBinary?, intersects, and setsrid

Fixed in http://trac.osgeo.org/qgis/changeset/15072/ QGIS r15072

comment:4 Changed 9 years ago by robe

Description: modified (diff)

Jef, Thanks.

comment:5 Changed 9 years ago by robe

Add to this list Mapnik. I tried generating OpenStreetMap tiles with my PostGIS 2.0 install, and it appears it uses at least the deprecated Extent function.

comment:6 Changed 9 years ago by robe

Okay according to Dane Springmeyer the upcoming Mapnik 2.0 scripts will not use deprecated functions:

So will just have to test these against our PostGIS 2.0. springmeyer - "Mapnik trunk, aka Mapnik 2.0, uses the latest ST_* functions, not the older ones. It will likely be released in late summer, the same time as PostGIS 2.0."

See thread here:

http://www.reddit.com/r/programming/comments/hgm1/building_tiles_with_postgis_openstreetmap_data/

comment:8 Changed 8 years ago by robe

Type: defecttask

comment:9 Changed 8 years ago by nicklas

I just bumped into :

RuntimeError: Postgis Plugin: PSQL error:
ERROR:  function setsrid(box3d, integer) does not exist

when trying to generate tiles with Mapnik 2.0 from http://ppa.launchpad.net/mapnik/nightly-trunk/ubuntu updated today.

In source I found it in their file: postgis_datasource.cpp

/Nicklas

comment:10 Changed 8 years ago by robe

nicklas -- can you report this on thier bug tracker. I think I did that for other such issues.

Anyrate we have this function in legacy_compatibility_layer.sql

Give that a try to install and see if you run into other issues after that.

comment:11 Changed 8 years ago by nicklas

Yes, I will report it.

I just installed setsrid, and it seems to work now.

So, probably they have fixed extent that you mentioned above.

comment:12 Changed 8 years ago by nicklas

Ok, SetSRID issue is fixed in Mapnik trunk. https://github.com/mapnik/mapnik/issues/1083

I guess it was not Mapnik 2.0 that I was testing as I wrote above but trunk, so I guess it will be in Mapnik 2.1

comment:13 Changed 8 years ago by pramsey

Bad news from the MapServer front, while I changed the ST_AsBinary call years ago, I had left in place a GeomFromText? call, so the current released MapServers? aren't going to work with PostGIS 2.0 out of the box. The next minor release to 6.0 will pick up the change though.

comment:14 Changed 8 years ago by pramsey

GeoServer? 2.1.3 seems happy w/ 2.0. No problems encountered adding and viewing a table.

comment:15 Changed 8 years ago by robe

Resolution: fixed
Status: newclosed

I'm going to consider this done.

comment:16 Changed 7 years ago by AlVigil

Resolution: fixed
Status: closedreopened

Am using gvSIG 1.12 RC2 with PostGIS 2.0.1,but am unable to add a Geodb to a View. The error message is

gvSIG had an unexpected problem. Current process was aborted. Error message is: Can´t read the driver: PostGIS JDBC Driver

Can you help me resolve this issue? I wrote a message to giSIG and they said the problem is with PostGis? 2.0.1, and that the version of gvSIG I am using does not support 2.0 and that they do not have the resources to solve this problem right now. Should I forgo the use of gvSIG? I really do not want to go back to an older version of PostGis?.

Please advice,

Al Vigil Developer, pchommes, inc., Addison, TX

comment:17 Changed 7 years ago by robe

Al,

You can try installing the legacy.sql file packaged with PostGIS 2.0 that is in share/contrib/postgis-2.0 folder (where the other PostGIS scripts are). That reinstalls all the legacy functions we took out and resolves many of these kinds of issues.

If that still doesn't work, can you turn on logging on your database and let us know what errors you are seeing in the logs.

to turn on logging do the following - replace mygisdb with the name of the database you are connecting to.

ALTER DATABASE mygisdb SET log_statement='all';

The logs are usually written to the pg_logs folder of your PostgreSQL data folder. Check the latest one -- usually notes the missing function or issue with call.

comment:18 Changed 7 years ago by robe

Forgot to say -- if you don't want a lot of bloat, first try legacy_minimal.sql and if you still get errors, then do legacy.sql. legacy.sql has a ton of extra functions (in addition to the minimal) that have been deprecated for years that most apps don't use.

comment:19 Changed 7 years ago by AlVigil

Resolution: fixed
Status: reopenedclosed

Robe,

Installing legacy.sql did the trick. I did this before I read the second email, to try the legacy_minimal first, but I do not mind the extra functions that are present.

Thank you for the prompt response.

Al Vigil

Note: See TracTickets for help on using tickets.