Opened 7 years ago

Closed 7 years ago

#2313 closed defect (fixed)

CUnit failure for force_sfs

Reported by: Bborie Park Owned by: colivier
Priority: medium Milestone: PostGIS 2.1.0
Component: postgis Version: master
Keywords: Cc:

Description

On OSX 10.6, I'm getting the following when running the CUnit tests.

Suite: force_sfs
  Test: test_sfs_11 ...cu_tester(50125) malloc: *** error for object 0x3: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
make[2]: *** [check] Abort trap
make[1]: *** [check] Error 2
make: *** [check] Error 1

Change History (10)

comment:1 Changed 7 years ago by Bborie Park

Owner: changed from pramsey to colivier

comment:2 Changed 7 years ago by Bborie Park

Failure doesn't occur on Linux 32 and 64-bit. Testing Windows 7 64-bit now.

comment:3 Changed 7 years ago by robe

I just checked my windows 64 mingw and seems okay. All regress pass, but I'm not compiling with sfcgal enabled yet.

comment:4 Changed 7 years ago by Bborie Park

I'm not compiling with CGAL yet either. Just finished running Windows 7 64-bit and no failures (stupid dll issues with testing loader/cunit though). Running 32-bit Windows 7 now. I'd double-check with OSX just to make sure it isn't me.

comment:5 Changed 7 years ago by robe

You are having issues with loader/cunit -- I'm still having those with winnie against 2.0, but for 2.1 its fine now both on winnie and my windows 7 64-bit. See #2158

comment:6 Changed 7 years ago by robe

just finished testing against 32-bit windows 7 against 9.2.4 EDB instance

PostgreSQL 9.2.4, compiled by Visual C++ build 1600, 32-bit
 - 2013-05-10 04:58:23
  GEOS: 3.4.0dev-CAPI-1.8.0 r0
  PROJ: Rel. 4.8.0, 6 March 2012

and seems to pass fine. My 64-bit EDB instance crashes, but that's nothing new.

I'll run a garden test next.

comment:7 Changed 7 years ago by Bborie Park

I got the loader/cunit tests to be happy once I copied over 2 geos dlls and libpq.dll to that directory.

Windows 7 32-bit passed with flying colors. Time to make sure I'm not delusional about OSX failing...

comment:8 Changed 7 years ago by colivier

I can reproduce it on OSX 10.6 too, i'm looking at it

comment:9 Changed 7 years ago by colivier

as r11395 it works not for me on OSX too

comment:10 Changed 7 years ago by Bborie Park

Resolution: fixed
Status: newclosed
Version: 2.0.xtrunk

Works for me as of r11411

Note: See TracTickets for help on using tickets.