Opened 7 years ago

Closed 8 months ago

#2158 closed defect (worksforme)

Possible issue with shp2pgsql-gui loader/dumper on windows

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS Fund Me
Component: buildbots Version: master
Keywords: mingw, windows Cc:

Description

Winnie has started coughing up blood when doing PostgreSQL 9.2.1 32-bit tests on loader/dumper gui. It's weird it is the only one and it started happening oddly enough when I made changes to PostGIS tiger geocoder extension which in theory should have nothing to do with the dumper gui. I tried rerunning regress to rule out flukiness and still failed. I'll reboot the server later to see if that helps.

     CUnit - A unit testing framework for C - Version 2.1-2
     http://cunit.sourceforge.net/


Suite: Shapefile Loader File shp2pgsql Test
  Test: test_ShpLoaderCreate() ...passed
  Test: test_ShpLoaderDestroy() ...make[2]: *** [check] Error 128
make[2]: Leaving directory `/c/jenkins/postgis/branches/2.1/loader/cunit'
make[1]: *** [check] Error 2
make[1]: Leaving directory `/c/jenkins/postgis/branches/2.1/loader'
make: *** [check] Error 1

Debbie doesn't do the gui test at all so hard to compare. I'm retesting on 9.1x64 to see if it will also fail to suggest flukiness.

Err 128 seems to be often caused by paranoid antivirus software so might be just the recent virus definition updates and have nothing to do with PostGIS.

strk -- no wise ass comments about windows :)

Change History (16)

comment:1 Changed 7 years ago by robe

okay definitely bizzarro. Just reran on 9.1x64 and that one works okay so it seems sudden weirdness with 9.2x32bit. Will try rerunning on 9.2x64

comment:2 Changed 7 years ago by robe

Okay 9.2x64 seems okay. Just the 9.2.1x32 bit mingw seems unhappy.

I'll next test with 2.0 branch and my local windows 7.

This is beginning to remind me of #2020 where only 9.2w32 exhibited failures and I had to rewrite regress test to get around the weirdness. But more weird since nothing in code base should have caused this. Still need to restart the server. Only other difference I can think of between this run and last pass is update of virus definition files on Microsoft security essentials.

comment:3 Changed 7 years ago by robe

I think winnie might be hainted.

I rebooted and that didn't help still 9.2.1 w32 failing and others are fine. It also fails on the 2.0 test branch.

I tested on my windows 7 64-bit again 9.2.1 w32 mingw and that passed fine though against EDB I'm getting some crashing in other areas which I'm checking on.

comment:4 Changed 7 years ago by robe

Resolution: fixed
Status: newclosed

well that was weird. After strk's recent json fixes tht broke my mingw build environment and having to change the json hack to not hack anymore, winnie's 9.2 win32 still refused to compile and waas complaining about some really old file in /usr/local/lwgeom.h or something that it couldn't remove. I deleted teh dnagling lwgeom.h file and low and behold 9.2 32-bit started to work again for both 2.0 and 2.1.

comment:5 Changed 7 years ago by robe

Resolution: fixed
Status: closedreopened

Happening again for 2.1.0 9.2 32-bit around r11204 . I suspect a dangling lwgeom somewhere but haven't found it.

comment:6 Changed 7 years ago by robe

Component: loader/dumperbuildbots

okay managed to test on my windows 7 64-bit mingw64-w32 chain and works fine. I'm suspecting a permission issue on winnie. One difference between the ming32 and ming64 folders on winnie is that I had given full rights to the Jenkins process in the ming64 folder, but not the ming32. I just did the same for ming32 and retesting now.

The shp2pgsql-gui may be creating files where it shouldn't be and that might be causing this random error that pops every once in a while and disappears.

comment:7 Changed 7 years ago by robe

nope no change :(. I'll run a procmon later to see what's going on.

comment:8 Changed 7 years ago by robe

Milestone: PostGIS 2.1.0PostGIS 2.2.0

comment:9 Changed 7 years ago by robe

Milestone: PostGIS 2.2.0PostGIS 2.1.0
Resolution: fixed
Status: reopenedclosed

would you believe commit r11310 made 9.2 32 regress succeed with shp2pgsql-gui.

I think there is some spooky stuff going on with our shp2pgsql-gui.

comment:10 Changed 7 years ago by robe

oops wrong revision: r11363 I should run 2.0 branch just to see if its still broken or got spookily fixed too.

comment:11 Changed 7 years ago by robe

Milestone: PostGIS 2.1.0PostGIS 2.0.4
Resolution: fixed
Status: closedreopened

yeh 2.0 is still broken. Next apply r11363 to 2.0 branch to see if it magically fixes the issue. I'll reopen this until I do that.

comment:12 Changed 7 years ago by robe

still broken for 2.0 after patch :(

comment:13 Changed 7 years ago by robe

Summary: Possible issue with gui loader/dumper on windowsPossible issue with shp2pgsql-gui loader/dumper on windows

This is seriously bugging me now. After I took out the geos include in the cunit tests at r11438, the 32-bit shp2pgsql-gui tests on winnie are failing again for 2.1 (though 64-bit are fine). I think there is something screwed up with the way liblwgeom is being bound to things (or its installing in random locations on my system I can't find and being picked up randomly by cunit). I could put back the geos include, but in theory the loader should not need it at all.

comment:14 Changed 6 years ago by robe

Milestone: PostGIS 2.0.4PostGIS Future

comment:15 Changed 2 years ago by robe

Milestone: PostGIS FuturePostGIS Fund Me

Milestone renamed

comment:16 Changed 8 months ago by robe

Resolution: worksforme
Status: reopenedclosed

I don't think this happens anymore.

Note: See TracTickets for help on using tickets.