Opened 7 years ago

Closed 7 years ago

#2314 closed defect (fixed)

postgis_full_version and postgis_sfcgal_version crashes service on windows 7 edb 64-bit

Reported by: robe Owned by: colivier
Priority: blocker Milestone: PostGIS 2.1.0
Component: sfcgal Version: master
Keywords: Cc:

Description

Okay got a really serious issue now. Even though I kind of ignore my edb 64-bit problems because well I know tests fail. I can't ignore this one.

I just did a

CREATE EXTENSION postgis;

Worked fine:

then a

select postgis_full_version();

Crashes the server. We can't go to beta if this is indeed a real issue.

Change History (7)

comment:1 Changed 7 years ago by robe

Log shows this:

STATEMENT:  CREATE EXTENSION postgis
LOG:  server process (PID 4080) was terminated by exception 0xC0000005
DETAIL:  Failed process was running: select postgis_full_version();
HINT:  See C include file "ntstatus.h" for a description of the hexadecimal value.
LOG:  terminating any other active server processes
WARNING:  terminating connection because of crash of another server process
DETAIL:  The postmaster has commanded this server process to roll back the current transaction and exit, because another server process exited abnormally and possibly corrupted shared memory.

comment:2 Changed 7 years ago by robe

Component: postgissfcgal
Owner: changed from pramsey to colivier
Summary: postgis_full_version crashes service on windows 7 edb 64-bitpostgis_full_version and postgis_sfcgal_version crashes service on windows 7 edb 64-bit

I have confirmed its the sfcgal check crashing my 64-bit EDB instance. If I remark out:

	BEGIN
		SELECT postgis_sfcgal_version() INTO sfcgalver;
	EXCEPTION
		WHEN undefined_function THEN
			sfcgalver := NULL;
	END; 

Works fine.

SELECT postgis_sfcgal_version();

crashes my windows EDB 64-bit backend

comment:3 Changed 7 years ago by colivier

Ok i guess you compiled it --without-sfcgal right ?

comment:4 Changed 7 years ago by colivier

I can reproduce it with --without-sfcgal under OSX, i'm looking at it

comment:5 Changed 7 years ago by robe

yes correct.

comment:6 Changed 7 years ago by colivier

Should been fixed as r11401

comment:7 Changed 7 years ago by colivier

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.