Opened 8 years ago

Closed 8 years ago

#1121 closed defect (fixed)

populate_geometry_columns using deprecated functions

Reported by: robe Owned by: pramsey
Priority: blocker Milestone: PostGIS 1.5.4
Component: postgis Version: 1.5.X
Keywords: Cc:

Description

We had fixed this in 2.0, but 1.5 still uses deprecated functions ndims and srid

Change History (4)

comment:1 Changed 8 years ago by robe

Owner: changed from pramsey to robe

comment:2 Changed 8 years ago by robe

Priority: mediumblocker

I think this one is an important one to fix before release. Will do later today. This one creates invalid constraints that don't load into PostGIS 2.0.0 cleanly without legacy install as I recall.

comment:3 Changed 8 years ago by robe

Owner: changed from robe to pramsey

Fixed at r9707

I added a regression test for this as well more or less copied from 2.0 branch. I also revised DropGeometryColumns? to use DROP TABLE IF EXISTS instead of DROP TABLE. Our minimum for 1.5 is 8.3 and DROP TABLE IF EXISTS has been supported since 8.2

The only thing left is to add this new test to regress/Makefile.in

Paul, can you do that for me?

I'm afraid to commit my version of the file since mine is a hacked up version because of issues I described in #1794

comment:4 Changed 8 years ago by pramsey

Resolution: fixed
Status: newclosed

Patched into the regress/Makefile.in at r9708

Note: See TracTickets for help on using tickets.