Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1794 closed defect (fixed)

make check under mingw doesn't work

Reported by: pramsey Owned by: pramsey
Priority: medium Milestone: PostGIS 1.5.4
Component: postgis Version: 1.5.X
Keywords: Cc:

Description

The code to figure out the root directory to install into doesn't work in the latest mingw variants. Same problem as existed in 2.0.

Change History (6)

comment:1 Changed 8 years ago by pramsey

Resolution: fixed
Status: newclosed

Fixed in r9702

comment:2 Changed 8 years ago by pramsey

And at r9703

comment:3 Changed 8 years ago by robe

FWIW this change breaks old mingw variants. Not that it matters except that I can't use the newer mingw's to compile the 32-bit chain because of the GEOS issues (with the newer GCC) without having to install a legacy VStudio VC++ Express companion. But I've gotten into the habit of hacking up my scripts to function, so carry on.

comment:4 Changed 8 years ago by pramsey

Can you say how it breaks them? The idea was just to do it enough differently that they would all work.

comment:5 Changed 8 years ago by robe

Hmm I'll double-check. I assumed you made the same change as you had done on 2.0 a while ago and I have a hacked script for 2.0 for my mingw 32-bit to get around it. I'll check next chance I get.

comment:6 Changed 8 years ago by robe

confirmed you change breaks my ability to regress. Though now I can't seem to get it back into a state I can compile.

The issue before is the old mingw doesn't like this line in regress/Makefile.in:

srcdir=$(shell bash -c "pwd -W")

So I would have a hacked script that has this instead:

srcdir=$(shell pwd -W)

but even that isn't working for me either:(

It's giving me a:

sed 's,$libdir,c:/projects/postgis/branches/1.5/regress/00-regress-install/lib,g' ../postgis/postgis.sql > postgis.sql
/bin/sh: ./run_test: No such file or directory
make[1]: *** [check] Error 127
make[1]: Leaving directory `/c/projects/postgis/branches/1.5/regress'
make: *** [check] Error 2

I have to also change the run_test from

#!/bin/bash

to

#!/bin/sh
Note: See TracTickets for help on using tickets.