Opened 8 years ago

Closed 5 years ago

#430 closed enhancement (fixed)

OSGeo4W installer 32 bits installs matplotlib 1.2.1 while 64 bits installs 1.3.0

Reported by: redl Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: matplotlib
Cc:

Description (last modified by jef)

Hi !

As said in the title : OSGeo4W installer 32 bits installs matplotlib 1.2.1 while the 64 bits installer installs 1.3.0

Is it possible to upgrade both to 1.3.x ?

I'm asking because I'm developing a QGIS plugin and need 1.3.x...

Thanks !

Change History (5)

comment:1 by jef, 8 years ago

Resolution: fixed
Status: newclosed

added matplotlib-1.3.1-1 to 32 and 64bit.

comment:2 by jef, 8 years ago

Description: modified (diff)
Resolution: fixed
Status: closedreopened

complains about pyparsing:

Python 2.7.4 (default, Apr  6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)] on Olivier-THINK
## Type help(iface) for more info and list of methods.

>>>import matplotlib
Traceback (most recent call last):
  File "<input>", line 1, in <module>
  File "D:/PROGRA~3/OSGeo4W/apps/qgis-dev/./python\qgis\utils.py", line 454, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "D:\PROGRA~3\OSGeo4W\apps\Python27\lib\site-packages\matplotlib-1.3.1-py2.7-win32.egg\matplotlib\__init__.py", line 129, in <module>
    "matplotlib requires pyparsing >= 1.5.6")
ImportError: matplotlib requires pyparsing >= 1.5.6

32bit is now back to 1.2.1-2 and 1.3.1-1 marked as "test".

comment:3 by pcav, 6 years ago

At least one plugin requires matplotlib >=1.3: https://github.com/olivierdalang/VectorBender It would be nice to have it upgraded also on 32bit. BTW, upstream matplotlib is 1.5

comment:4 by jef, 6 years ago

Keywords: matplotlib added

comment:5 by jef, 5 years ago

Resolution: fixed
Status: reopenedclosed

matplotlib updated to 2.0.0.

Note: See TracTickets for help on using tickets.