Opened 7 years ago

Closed 10 months ago

#429 closed defect (wontfix)

lasinfo crash by laz-file

Reported by: hellik Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: libLAS, laszip, 32-bit
Cc: neteler

Description

in OSGeo4W-32bit the liblas-tools seems to be compiled with laszip-functionality

C:\Windows\System32>lasinfo --help
--------------------------------------------------------------------
    lasinfo (libLAS 1.7.0 with GeoTIFF 1.3.0 GDAL 1.8.1 LASzip 2.1.0)
--------------------------------------------------------------------

but laz-files (e.g. test.laz or lake.laz from LAStools) crashes e.g. lasinfo.

Change History (6)

comment:1 Changed 7 years ago by neteler

Cc: neteler added
Keywords: libLAS added

comment:2 Changed 7 years ago by hobu

I'm pretty sure the problem is cross-heap freeing, and LASzip must be compiled with a different runtime than libLAS. I have recently built and added libLAS 1.8.0 and LASzip 2.1.0 to OSGeo4W-64bit and it seems to be working.

comment:3 Changed 7 years ago by hellik

Keywords: 32-bit added

comment:4 in reply to:  2 ; Changed 7 years ago by hellik

Replying to hobu:

I'm pretty sure the problem is cross-heap freeing, and LASzip must be compiled with a different runtime than libLAS. I have recently built and added libLAS 1.8.0 and LASzip 2.1.0 to OSGeo4W-64bit and it seems to be working.

I can confirm that it works in OSGeo4W-64bit, it still crashes in OSGeo4W-32bit.

any chance to fix it also for OSGeo4W-32bit?

thanks Helmut

comment:5 in reply to:  4 Changed 7 years ago by lucadelu

Replying to hellik:

Replying to hobu:

I'm pretty sure the problem is cross-heap freeing, and LASzip must be compiled with a different runtime than libLAS. I have recently built and added libLAS 1.8.0 and LASzip 2.1.0 to OSGeo4W-64bit and it seems to be working.

I can confirm that it works in OSGeo4W-64bit, it still crashes in OSGeo4W-32bit.

any chance to fix it also for OSGeo4W-32bit?

I would like to have libLAS 1.8.0 and LASzip 2.1.0 to OSGeo4W-32bit

thanks Helmut

Thanks Luca

comment:6 Changed 10 months ago by jef

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.