Opened 11 years ago

Closed 9 years ago

#555 closed defect (fixed)

v.in.gpsbabel on wingrass: g.proj error

Reported by: hamish Owned by: grass-dev@…
Priority: minor Milestone: 6.4.0
Component: Vector Version: 6.4.0 RCs
Keywords: wingrass, v.in.gpsbabel, g.proj Cc:
CPU: x86-32 Platform: MSWindows XP

Description

Hi,

when running v.in.gpsbabel on wingrass (latest 6.4.0svn) a window pops up that says that g.proj.exe has exited unexpectedly. but then the modules mostly works fine. (but data is not automatically reprojected to the current location; it stays in wgs84 lat/lon)

'g.proj -jf' works fine from the wxGUI command prompt thingie.

?? Hamish

Change History (10)

comment:1 Changed 10 years ago by neteler

Keywords: wingrass added

Does the problem persist with a recent installer from http://josef.fsv.cvut.cz/wingrass/grass64/ ?

comment:2 Changed 10 years ago by hamish

Yes, still happens with the6.4.0svn r40456 binary build.

I can confirm that it happens on this line of the script:

OUT_PROJ="g.proj -jf"

running that from the MSys terminal prompt works as expected.

??, Hamish

comment:3 Changed 10 years ago by neteler

Could you try to remove -f from that line in the script? Just to see which if the "dontprettify" is the problem?

Markus

comment:4 Changed 10 years ago by hamish

Still breaks with -f removed. $? is "5".

even if I put "g.proj -p" in the script just before the OUT_PROJ=`g.proj -jf` line that dies with exit code 5 too.

... so what does exit code 5 mean in WinXP?

"g.proj --help" in the script does work as expected and exits with $?==0.

Hamish

comment:5 in reply to:  4 Changed 10 years ago by hamish

Replying to hamish:

Still breaks with -f removed. $? is "5".

apparently exit code 5 is "ERROR_ACCESS_DENIED".

http://msdn.microsoft.com/en-us/library/ms681382(VS.85).aspx

It could be for the PROJ_INFO file, but as the program works fine from the command line I'm not sure what to make it.

Hamish

comment:6 Changed 10 years ago by hamish

I would guess that these modules would also be affected-

m.proj
r.in.aster
r.in.wms
r.tileset
v.in.garmin
v.in.geonames
v.in.gns
v.in.gpsbabel

but e.g. m.proj works fine:

#spearfish
g.region -l | grep center
echo "103d45'W 44d26'15N" | m.proj -i

very weird. can anyone else reproduce this bug? my test case is importing a GPX track file into a lat/long location.

??, Hamish

comment:7 Changed 10 years ago by hamish

see also #827

comment:8 Changed 10 years ago by hamish

I am still completely baffled by this one.

why does g.proj consistently fail in one particular script with exit code 5, "ERROR_ACCESS_DENIED", and yet works fine from the MSys command line and in other scripts?

Hamish

comment:9 in reply to:  8 Changed 9 years ago by mmetz

Replying to hamish:

I am still completely baffled by this one.

why does g.proj consistently fail in one particular script with exit code 5, "ERROR_ACCESS_DENIED", and yet works fine from the MSys command line and in other scripts?

Just tested v.in.gpsbabel on a recent (r42640) wingrass installation, works fine, coordinates are properly reprojected, seems to be fixed.

Markus M

comment:10 Changed 9 years ago by hamish

Resolution: fixed
Status: newclosed

tested on XP using last night's 6.5svn nightly build, imports and reprojects data fine. I'm not sure why though, there hasn't been a change to the g.proj code in a year AFAICT. maybe it was the spawn() code or missing manifest?

still need to retest with 6.4.0, but closing bug as it seems fixed.

Hamish

Note: See TracTickets for help on using tickets.