Opened 11 years ago

Closed 11 years ago

#556 closed defect (duplicate)

ftbfs: g.cairocomp

Reported by: hamish Owned by: grass-dev@…
Priority: major Milestone: 7.0.0
Component: Default Version: svn-trunk
Keywords: g.cairocomp Cc:
CPU: x86-32 Platform: Linux

Description

Hi,

when building grass 7 I get the following error in g.cairocomp:

main.c: In function 'init_xlib':
main.c:118: error: implicit declaration of function 'cairo_xlib_surface_get_xrender_format'
main.c:118: warning: assignment makes pointer from integer without a cast
make: *** [OBJ.i686-pc-linux-gnu/main.o] Error 1

I have libcairo2-dev version 1.2.4, the fn is not found in /usr/include/cairo/*.h

This change says that >=1.5.8 is now needed: http://trac.osgeo.org/grass/changeset/36349

Could a check be added to ./configure to test for cairo_xlib_surface_get_xrender_format()?

thanks, Hamish

Change History (1)

comment:1 Changed 11 years ago by hamish

Resolution: duplicate
Status: newclosed

oops, dupe of #419.

closing.

Note: See TracTickets for help on using tickets.