Opened 3 years ago

Closed 19 months ago

#3223 closed defect (fixed)

r.info displays wrong timestamp after t.rast.series with a where clause

Reported by: veroandreo Owned by: grass-dev@…
Priority: normal Milestone: 7.4.1
Component: Default Version: svn-trunk
Keywords: r.info Cc:
CPU: Unspecified Platform: Linux

Description

If I run t.rast.series using a where clause, r.info of the resulting map shows the timestamp of the whole time series and not that of the temporal selection performed with where.

The selection of maps is fine given that I get the right list of maps when using the same where clause in t.rast.list, and the values of resulting maps using the whole time series or just a selection, differ as expected.

Here is a reproducible example:

r.mapcalc expression="prec_1 = 100" --o
r.mapcalc expression="prec_2 = 200" --o
r.mapcalc expression="prec_3 = 300" --o
r.mapcalc expression="prec_4 = 400" --o
r.mapcalc expression="prec_5 = 500" --o
r.mapcalc expression="prec_6 = 600" --o

t.create type=strds temporaltype=absolute \
    output=precip_abs title="Example" \
    descr="Example" --o

t.register -i type=raster input=precip_abs \
    maps=prec_1,prec_2,prec_3,prec_4,prec_5,prec_6 \
    start="2001-01-01" increment="1 months" --o

t.rast.series input=precip_abs output=precip_abs_average

r.info precip_abs_average

t.rast.series input=precip_abs output=precip_abs_average_3months \ 
where="start_time >= '2001-04-01'"

r.info precip_abs_average_3months

t.rast.list precip_abs where="start_time >= '2001-04-01'"

Change History (6)

comment:1 Changed 23 months ago by neteler

Milestone: 7.4.07.4.1

Ticket retargeted after milestone closed

comment:2 Changed 21 months ago by huhabla

Fixed in grass trunk revision r72479. Please test.

Last edited 21 months ago by huhabla (previous) (diff)

comment:3 in reply to:  2 Changed 21 months ago by neteler

Replying to huhabla:

Fixed in grass trunk revision r72479. Please test.

Quick question: should test_t.sereis_bug_3223.sh be in trunk and be backported?

comment:4 in reply to:  2 Changed 21 months ago by veroandreo

Replying to huhabla:

Fixed in grass trunk revision r72479. Please test.

After testing, I backported to release branch 74 in r72493 and to release branch 72 in r72499 (this last one without test_t.sereis_bug_3223.sh)

Thanks!

comment:5 Changed 20 months ago by neteler

Please close the ticket if issue is solved.

comment:6 in reply to:  5 Changed 19 months ago by veroandreo

Resolution: fixed
Status: newclosed

Replying to neteler:

Please close the ticket if issue is solved.

I had left it open because there's an open question (see comment 3). However, since the issue is fixed, I close it now. Re-open if needed.

Note: See TracTickets for help on using tickets.