Opened 3 years ago

Closed 13 months ago

#3222 closed defect (worksforme)

Add layer with table in Attribute table manager fails

Reported by: pvanbosgeo Owned by: grass-dev@…
Priority: normal Milestone: 7.6.2
Component: wxGUI Version: svn-trunk
Keywords: dbmgr Cc:
CPU: Unspecified Platform: Unspecified

Description

I am trying to add a layer with attribute table to a vector layer using the Attribute Table Manager, following the steps:

  • Go to to the tab 'Manage layers' and then the tab 'add layer'
  • Create a table using the 'create table' option.
  • add a layer with the 'insert record for each category into table' option toggled.

This results in an error window "ERROR: Layer index out of range".

Adding a layer and table with v.category and v.add.table works

Change History (4)

comment:1 Changed 3 years ago by martinl

Component: DefaultwxGUI
Keywords: dbmgr added
Milestone: 7.0.6

comment:2 in reply to:  description Changed 3 years ago by hellik

Replying to pvanbosgeo:

I am trying to add a layer with attribute table to a vector layer using the Attribute Table Manager, following the steps:

  • Go to to the tab 'Manage layers' and then the tab 'add layer'
  • Create a table using the 'create table' option.
  • add a layer with the 'insert record for each category into table' option toggled.

This results in an error window "ERROR: Layer index out of range".

Adding a layer and table with v.category and v.add.table works

confirmed on testing at

System Info                                                                     
GRASS version: 7.3.svn                                                          
GRASS SVN revision: r70070                                                      
Build date: 2016-12-13                                                          
Build platform: x86_64-w64-mingw32                                              
GDAL: 2.1.2                                                                     
PROJ.4: 4.9.3                                                                   
GEOS: 3.5.0                                                                     
SQLite: 3.14.1                                                                  
Python: 2.7.5                                                                   
wxPython: 2.8.12.1                                                              
Platform: Windows-8-6.2.9200 (OSGeo4W)  

comment:3 Changed 2 years ago by neteler

Milestone: 7.0.67.0.7

comment:4 Changed 13 months ago by martinl

Milestone: 7.0.77.6.2
Resolution: worksforme
Status: newclosed

Unable to reproduce in GRASS 7.6.0

Note: See TracTickets for help on using tickets.