Opened 7 years ago

Closed 7 years ago

#1729 closed defect (fixed)

Add 3d raster does not open GUI

Reported by: helena Owned by: martinl
Priority: blocker Milestone: 6.4.3
Component: wxGUI Version: svn-releasebranch64
Keywords: volume, wxnviz, d.rast3d Cc: grass-dev@…
CPU: OSX/Intel Platform: MacOSX

Description

3D raster cannot be added to GIS manager and cannot be visualized with wxnviz, it gives the following error

Unable to fetch interface description for command 'd.rast3d'. Details: [Errno 2] No such file or directory

So it cannot find the command. I couldn't find any solution, maybe someone else knows what's going on? I found related ticket here [1]. [1] http://trac.osgeo.org/grass/ticket/1515

see also https://trac.osgeo.org/grass/ticket/1692 and friends.

d.rast3d.py fails because it is not in the PATH.

This trick helps (for testing):

ln -s $HOME/grass64/gui/wxpython/scripts/d.rast3d.py $GISBASE/scripts/ chmod a+x $GISBASE/scripts/d.rast3d.py

Markus _

Attachments (1)

NVIZ_volume_crash.txt (71.7 KB) - added by cmbarton 7 years ago.
Error message from NVIZ and wxGUI crash that happens every time I adjust a parameter for a volume in the 3D display

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by martinl

Cc: grass-dev@… added
Keywords: d.rast3d added
Owner: changed from grass-dev@… to martinl
Status: newassigned

Please could you try r53163 (GRASS 6.5)?

comment:2 in reply to:  1 ; Changed 7 years ago by helena

Replying to martinl:

Please could you try r53163 (GRASS 6.5)?

I just tried it and it works - I can add the 3d raster and the isosurfaces work as well.

Thanks a lot, Helena

comment:3 Changed 7 years ago by cmbarton

I will try this tomorrow too. I hope it allows me to actually visualize a 3D volume finally. Thanks for working on this.

Michael

comment:4 in reply to:  2 Changed 7 years ago by martinl

Replying to helena:

Replying to martinl:

Please could you try r53163 (GRASS 6.5)?

I just tried it and it works - I can add the 3d raster and the isosurfaces work as well.

Backported to relbr64 in r53168. We can close the ticket when confirmed that it works also in GRASS 6.4.3svn.

Changed 7 years ago by cmbarton

Attachment: NVIZ_volume_crash.txt added

Error message from NVIZ and wxGUI crash that happens every time I adjust a parameter for a volume in the 3D display

comment:5 Changed 7 years ago by cmbarton

This is better but still not working for me. I can now add a 3D raster to the layer tree and open the 3D display. But I am unable to display a volume that I created and have displayed previously. I can add a slice or an isosurface. But as soon as I try to change any setting for either, the entire GUI crashes. I will attach the error message that I sent to Anna previously in case someone else can figure this out. Note that whenever I quit the GUI after using the 3D manager, I also get a similar error message.

comment:6 in reply to:  5 Changed 7 years ago by martinl

Resolution: fixed
Status: assignedclosed

Replying to cmbarton:

This is better but still not working for me. I can now add a 3D raster to the layer tree and open the 3D display. But I am unable to display a volume that I created and have displayed previously. I can add a slice or an isosurface. But as soon as I try to change any setting for either, the entire GUI crashes. I will attach the error message that I sent to Anna previously in case someone else can figure this out. Note that whenever I quit the GUI after using the 3D manager, I also get a similar error message.

Please create for this a new bug report. I am closing this ticket because reported bug has been already fixed.

Note: See TracTickets for help on using tickets.