Opened 7 years ago

Closed 7 years ago

#1730 closed defect (invalid)

GRASS 6.4.2 libgdal (GDAL 1.9.1) Disconnect

Reported by: osgeodls Owned by: grass-dev@…
Priority: normal Milestone: 6.4.3
Component: Packaging Version: 6.4.2
Keywords: libgdal.so Cc:
CPU: Unspecified Platform: Linux

Description (last modified by hamish)

When trying to run GRASS 6.4.2 under Linux (Ubuntu 10.04 LTS) I get the following error message to the console on startup:

/usr/local/lib/libgdal.so.1: no version information available (required by /usr/lib/grass64/lib/libgrass_vect.6.4.2.so)

Is there a procedure 'fix' for this ? I downloaded gdal and compiled it to get rid of a prior error message from 'ogr2ogr' about a version mismatch but now when I launch gis.m I get:

"g.proj or projection error: g.proj /usr/local/lib/libgdal.so.1: no version information available (required by g.proj) - g.proj: /usr/local/lib/libgdal.so.1: no version information available (required by /usr/lib/grass64/libgrass_gproj.6.4.2.so)

Can I assume this is a GRASS-only problem, as QGIS (1.9.0) seems fine with use of the PROJ library, as is ?

Change History (1)

comment:1 Changed 7 years ago by hamish

Component: DefaultPackaging
Description: modified (diff)
Keywords: libgdal.so added
Platform: UnspecifiedLinux
Resolution: invalid
Status: newclosed

If you compile your own copy of GDAL, you should remove any gdal packages fro Ubuntu or UbuntuGIS, and recompile GRASS and QGIS from source code to match your new libraries.

A GRASS built for a specific version of gdal only works with that version due to ABI/API compatibility issues.

see the debian/README.debian file in the grass source code, and the compile and install pages in the grass wiki for hints on how to rebuild grass from source.

Hamish

Note: See TracTickets for help on using tickets.