Opened 7 years ago

Closed 3 years ago

#1703 closed enhancement (worksforme)

wxGUI vector and raster querying

Reported by: wenzeslaus Owned by: grass-dev@…
Priority: major Milestone: 7.0.5
Component: wxGUI Version: unspecified
Keywords: Cc: grass-dev@…
CPU: Unspecified Platform: Unspecified

Description

The current state of map querying in wxGUI is not sufficient and some general solution (from user point of view) is needed.

Wider discussion is necessary but there are some known problems already.

Several inconsistencies and problems:

  • different text formatting for vector and raster
  • for vector map with db table dialog is displayed but for map without only v.what output is printed
  • vector attribute dialog is editable
  • coordinates are displayed only sometimes
  • for vector map with some layers with db table and some without, only layers with are displayed

Highly related tickes:

  • #251 Enhancements to vector querying
  • #304 quering disables vector transparency
  • #523 wxGUI: querying a vector map in edit mode does nothing
  • #547 Raster query in wxGUI
  • #951 Error querying rasters in wxgui
  • #1402 Allow input coordinates to v.what to create a bounding rectangle for querying
  • #1469 wxgui vector query doesn't work for maps without attribute table
  • #1522 dbm_base.py fails with multilayer maps
  • #1606 attribute query tool reports "nothing found" when clicking on a vector object
  • #1607 attribute query fails to display text attribute values
  • #1608 WXGUI attribute query might lead to accidental attribute data editing
  • #1609 WXGUI doesn't offer a supported encodings for "Attribute data encoding" setting

Other related tickets:

  • #281 query tool crashes when the user presses mouse buttons fast
  • #650 No warning when querying grid layer
  • #897 WinGrass: error with "Query vector map (edit mode)"
  • #941 add a query coordiantes under current cursor position
  • #1651 Map display Query Vector tool fails

Change History (6)

comment:1 Changed 7 years ago by marisn

Many of listed issues have been solved, still without significant overhaul of whole system :( Could this be a GSoC task?

Another related issue: #1824

comment:2 Changed 7 years ago by annakrat

Another ticket about querying in d.mon: #1826

comment:3 Changed 6 years ago by martinl

Recently reimplemented in trunk. Anything left?, could we closed this ticket?

comment:4 in reply to:  3 Changed 6 years ago by wenzeslaus

Replying to martinl:

Recently reimplemented in trunk. Anything left?, could we closed this ticket?

From me, everything is fulfilled. Only the last point was not tested (for vector map with some layers with db table and some without, only layers with db table are displayed). But this may be caused by v.what behavior.

For further reference, here is the list of still open related tickets:

  • #251 Enhancements to vector querying
  • #304 quering disables vector transparency
  • #523 wxGUI: querying a vector map in edit mode does nothing
  • #1402 Allow input coordinates to v.what to create a bounding rectangle for querying
  • #1824 wxGUI should offer a vector geometry query tool
  • #1826 New d.mon doesn't allow querying (can be closed soon)

comment:5 Changed 3 years ago by martinl

Milestone: 7.0.07.0.5

comment:6 Changed 3 years ago by martinl

Resolution: worksforme
Status: newclosed

No activity last 4 years. Closing, feel free to reopen if needed.

Note: See TracTickets for help on using tickets.