Opened 11 years ago

Closed 3 years ago

#523 closed defect (worksforme)

wxGUI: querying a vector map in edit mode does nothing

Reported by: msieczka Owned by: martinl
Priority: major Milestone: 6.4.6
Component: Translations Version: svn-develbranch6
Keywords: Cc: grass-dev@…
CPU: All Platform: All

Description

  1. Load a vector map.
  1. Zoom to it.
  1. Query the map in "edit mode" - nothing happens. In vdigit query and editing works.

SVN r36231.

Change History (18)

comment:1 Changed 11 years ago by martinl

Seems to work for me. Can you post NC-based example?

Martin

comment:2 in reply to:  1 ; Changed 11 years ago by hellik

Replying to martinl:

Seems to work for me. Can you post NC-based example?

Martin

grass64rc3-3 (osgeo4w) - win vista data nc-spm

g.copy vect=lakes@PERMANENT,test

loading test in wx-gis-map-display

querying test map in edit mode => window for update attributes pop up

but submit a change for example in the field "FTYPE" (character) from RESERVOIR to DAM

then following error message:

Traceback (most recent call last):

File "C:\OSGeo4W\apps\grass\grass-6.4.0RC3\etc\wxpython\gu

i_modules\dbm.py", line 3101, in OnSubmit?

"input=%s" % sqlFile.name])

File "C:\OSGeo4W\apps\grass\grass-6.4.0RC3\etc\wxpython\gu

i_modules\gcmd.py", line 355, in init

_("Error: ") + self.GetError?())) gui_modules.gcmd . CmdError?

Helmut

comment:3 in reply to:  1 ; Changed 11 years ago by msieczka

Replying to martinl:

Seems to work for me. Can you post NC-based example?

Seems translation-related issue. I can reproduce it for any vector map, but *only in Polish translation*. After "export LC_ALL=C" works fine.

Spearfish example:

  1. start GRASS
  1. add "streams" vector map
  1. select it, "Zoom to selected map"
  1. in "Map display" window: "Query raster/vector maps" > "Query vector map (edit mode)"
  1. left click a line on the map display - nothing happens

Querying vectors works fine though in "display mode" even in Polish translation.

Reminds me of http://trac.osgeo.org/grass/ticket/427#comment:5. Are there more such issues possible?

comment:4 Changed 11 years ago by neteler

I found this which looks suspicious:

 #: ../gui/wxpython/gui_modules/mapdisp.py:163
 msgid "Render"
-msgstr "_Renderuj"
+msgstr "Renderuj"

Could you fix that locally and regenerate the mo file?

Markus

comment:5 in reply to:  2 Changed 11 years ago by martinl

Replying to hellik:

Traceback (most recent call last):

File "C:\OSGeo4W\apps\grass\grass-6.4.0RC3\etc\wxpython\gu

i_modules\dbm.py", line 3101, in OnSubmit?

"input=%s" % sqlFile.name])

File "C:\OSGeo4W\apps\grass\grass-6.4.0RC3\etc\wxpython\gu

i_modules\gcmd.py", line 355, in init

_("Error: ") + self.GetError?())) gui_modules.gcmd . CmdError?

Fixed in r36377.

comment:6 in reply to:  3 ; Changed 11 years ago by martinl

Cc: grass-dev@… added
Owner: changed from grass-dev@… to martinl
Status: newassigned

Replying to msieczka:

Seems translation-related issue. I can reproduce it for any vector map, but *only in Polish translation*. After "export LC_ALL=C" works fine.

yes, it's problem with v.what. Temporally fixed in r36378. v.what should have script-style output which is not based on used locales.

comment:7 Changed 11 years ago by msieczka

In r36380 the problem is still not fixed.

comment:8 in reply to:  7 ; Changed 11 years ago by martinl

Replying to msieczka:

In r36380 the problem is still not fixed.

export LC_ALL=pl_PL.utf8

grass65
  • add vector, zoom, query in edit mode

works. M.

comment:9 in reply to:  8 Changed 11 years ago by msieczka

Replying to martinl:

Replying to msieczka:

In r36380 the problem is still not fixed.

export LC_ALL=pl_PL.utf8

grass65
  • add vector, zoom, query in edit mode

works

True :). However, without explicit "export LC_ALL=pl_PL.utf8" it still doesn't.

My default locale settings are:

$ locale
LANG=pl_PL.UTF-8
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
LC_TIME="pl_PL.UTF-8"
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY="pl_PL.UTF-8"
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER="pl_PL.UTF-8"
LC_NAME="pl_PL.UTF-8"
LC_ADDRESS="pl_PL.UTF-8"
LC_TELEPHONE="pl_PL.UTF-8"
LC_MEASUREMENT="pl_PL.UTF-8"
LC_IDENTIFICATION="pl_PL.UTF-8"
LC_ALL=

comment:10 in reply to:  6 Changed 11 years ago by glynn

Replying to martinl:

Seems translation-related issue. I can reproduce it for any vector map, but *only in Polish translation*. After "export LC_ALL=C" works fine.

yes, it's problem with v.what. Temporally fixed in r36378.

Not really; see comment:9. It also needs to set LC_MESSAGES.

BTW, the GUI should leave os.environ alone; pass env=... to Popen() to control the environment for child processes.

v.what should have script-style output which is not based on used locales.

Agreed. Setting LC_MESSAGES is overkill (LC_ALL more so), as it will also affect error messages meant for the user.

comment:11 Changed 10 years ago by cmbarton

Component: wxGUITranslations

It's not clear whether this is fixed or not. But in either case, it is not a GUI problem but a problem with translations and and how they interact with grass modules like v.what. I'm changing the component to "translations". Maybe someone with another localization can see if it is fixed or not.

Michael

comment:12 Changed 7 years ago by martinl

Asking the reporter, is this ticket still relevant to the recent version - 6.4.3svn?

comment:13 in reply to:  12 Changed 6 years ago by mlennert

Resolution: worksforme
Status: assignedclosed

Replying to martinl:

Asking the reporter, is this ticket still relevant to the recent version - 6.4.3svn?

As there has been no response for 10 months, I'm closing this ticket.

Moritz

comment:14 Changed 6 years ago by hamish

Resolution: worksforme
Status: closedreopened

Please confirm bugs as fixed before closing them.

thanks, Hamish

comment:15 Changed 6 years ago by mlennert

This was for 6.4.0 where wxgui was still an infant. Much of the layer interrogation features has significantly changed since then.

I cannot reproduce these issues on Debian GNU/Linux (in GRASS7 there is no interactive editing of attributes outside the digitiser, AFAIK).

Can someone test on Windows ?

Moritz

comment:16 Changed 3 years ago by neteler

Milestone: 6.4.06.4.6

comment:17 Changed 3 years ago by mlennert

Again, no response since over 3 years, so I would propose to close this.

comment:18 Changed 3 years ago by martinl

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.