Opened 6 years ago

Closed 6 years ago

#802 closed defect (duplicate)

geos-3.6.1 fails while compiling for android-ndk due to missing include for fabs

Reported by: mj10777 Owned by: geos-devel@…
Priority: major Milestone: 3.6.1
Component: Default Version: 3.6.0
Severity: Unassigned Keywords:
Cc:

Description

While compiling a spatialite library for android (with rttopo)

  • new methods using 'fabs' fail

geos-3.6.1/src/algorithm/MinimumDiameter.cpp: In static member function 'static geos::geom::LineSegment geos::algorithm::MinimumDiameter::computeSegmentForLine(double, double, double)':

geos-3.6.1/src/algorithm/MinimumDiameter.cpp:370:12: error: 'fabs' was not declared in this scope

Adding:

#include <math.h> /* fabs */

resolves this.

Change History (1)

comment:1 by strk, 6 years ago

Resolution: duplicate
Status: newclosed

This is actually a duplicate of #799, which wasn't backported yet.

Note: See TracTickets for help on using tickets.