Opened 5 years ago

Closed 14 months ago

#6042 closed enhancement (wontfix)

Intelligent editing of Shapefiles with ESRI spatial indexes

Reported by: aharfoot Owned by: warmerdam
Priority: normal Milestone: closed_because_of_github_migration
Component: default Version: unspecified
Severity: normal Keywords:
Cc:

Description

Currently the read only limitation of GDAL's support for ESRI spatial indexes can quickly lead to them becoming out of sync with the spatial objects if the latter are edited through GDAL. I can think of a few solutions to this that might be implemented:

  1. Make the default behaviour of GDAL to not use SBN/SBX ESRI indexes if present.
  1. Automatically build and switch to a QIX index if a shapefile using SBN/SBX ESRI indexes is edited through GDAL.
  1. Implement SBN/SBX ESRI index writing and updating functionality!

Change History (2)

comment:1 Changed 5 years ago by Even Rouault

Regarding 1, if a shapefile is edited through the OGR API, the .sbn/.sbx should normally be currently deleted to avoid using their obsolete versions. If not, a reproducable scenario that would demonstrate a failure in removing them would be interesting.

Option 3 would certainly be the most interesting one. Patches or funding to do it are welcome.

comment:2 Changed 14 months ago by Even Rouault

Milestone: closed_because_of_github_migration
Resolution: wontfix
Status: newclosed

This ticket has been automatically closed because Trac is no longer used for GDAL bug tracking, since the project has migrated to GitHub?. If you believe this ticket is still valid, you may file it to https://github.com/OSGeo/gdal/issues if it is not already reported there.

Note: See TracTickets for help on using tickets.