Opened 10 years ago

Closed 10 years ago

#4790 closed defect (fixed)

Bad performance on large ECW when reading 1x1 windows

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 1.9.2
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: ecw picking
Cc:

Description

Linked to the following QGIS thread :

http://lists.osgeo.org/pipermail/qgis-developer/2012-August/021820.html

I've reproduced the issue with the following ECW : http://laillisettorrentit.net/index.php?page=torrent-details&id=d2c502c1aec3cce0180d92b31721597cbb523751 (1.8 GB, 141970x141970)

The issue is that establishing a view for a full scanline is overkill when wanting to read a single pixel.

Change History (1)

comment:1 by Even Rouault, 10 years ago

Milestone: 1.9.2
Resolution: fixed
Status: newclosed

Fixed in trunk (r24840) and branches/1.9 (r24841).

Note: See TracTickets for help on using tickets.