Opened 14 years ago

Closed 12 years ago

#1853 closed defect (fixed)

KML Driver - Placemark with Multigeometry Polygons fails

Reported by: darkblueB Owned by: warmerdam
Priority: normal Milestone: 1.6.1
Component: OGR_SF Version: unspecified
Severity: normal Keywords: kml
Cc:

Description

attempt to read a KML 2.1 file with a Placemark containing Multigeometry,

multiple Polygons, each with one outer boundary and multiple inner boundaries, fails

the "no layers found" msg is misleading turning CPL_DEBUG on shows some parsing detail

Attachments (1)

cropcircletk.kml (40.0 KB) - added by darkblueB 14 years ago.

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by darkblueB

Attachment: cropcircletk.kml added

comment:1 Changed 14 years ago by Even Rouault

This is a duplicate of #1803

comment:2 Changed 12 years ago by Even Rouault

Milestone: 1.6.1

In trunk (r16908) and branches/1.6 (r16909) : "KML: Add support for reading MultiGeometry? and layers with mixed geometry type. Avoid quadratic complexity when reading KML files. Advertize 25D geometry type when relevant"

Test improved in r16910

comment:3 Changed 12 years ago by Even Rouault

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.