Opened 14 years ago

Closed 12 years ago

#1803 closed enhancement (fixed)

KML: Documents with multiple geometry types are not supported

Reported by: crschmidt Owned by: Didge
Priority: normal Milestone: 1.6.1
Component: OGR_SRS Version: unspecified
Severity: normal Keywords: kml
Cc: warmerdam, Mateusz Łoskot

Description

FeatureServer? generates KML with multiple geometry types in the same layer. Currently, GDAL fails to read these. It would be nice if they could all be provided in one layer, or, if that's not possible, to create seperate layers for each geometry type.

File attached is example file which can be used to test this behavior, if it is developed.

Attachments (2)

2features.kml (1.5 KB) - added by crschmidt 14 years ago.
multiple geometry types
multi.patch (836 bytes) - added by crschmidt 14 years ago.

Download all attachments as: .zip

Change History (6)

Changed 14 years ago by crschmidt

Attachment: 2features.kml added

multiple geometry types

comment:1 Changed 14 years ago by warmerdam

Cc: warmerdam Mateusz Łoskot added
Keywords: kml added
Owner: changed from warmerdam to Didge

Changed 14 years ago by crschmidt

Attachment: multi.patch added

comment:2 Changed 14 years ago by crschmidt

Patch attached causes the behavior I had hoped for, at least at the base level.

comment:3 Changed 14 years ago by Even Rouault

#1853 is a duplicate of this one

comment:4 Changed 12 years ago by Even Rouault

Milestone: 1.6.1
Resolution: fixed
Status: newclosed

In trunk (r16908) and branches/1.6 (r16909) : "KML: Add support for reading MultiGeometry? and layers with mixed geometry type. Avoid quadratic complexity when reading KML files. Advertize 25D geometry type when relevant"

Test improved in r16910

Note: See TracTickets for help on using tickets.