Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#220 closed defect (fixed)

Selection hides other features in IE6

Reported by: chrisclaydon Owned by: madair
Priority: P1 Milestone: 2.0
Component: Widgets Version: SVN
Severity: Major Keywords:
Cc: Browser: IE6
External ID: 1193382.01 Operating System: All
state: Analysis Requested

Description

This occurs in the fusion-mg21 branch:

Open a layout based on the Sheboygan sample map in IE6.

Select a feature.

The selection appears, but the rest of the map becomes obscured - this could be a problem with PNG transparency in IE6(?)

If a rectangle is dragged to select. An error dialog is displayed referencing an MgClassNotFoundException.

Change History (11)

comment:1 by chrisclaydon, 13 years ago

Browser: AllIE6
state: NewAnalysis Requested

comment:2 by madair, 13 years ago

Status: newassigned

I'm unable to reproduce any of these errors. Testing with IETester in IE6 mode, Fusion trunk and the fusion2-mg21 branch, standard template with the Sheboygan sample dataset (and Fusiont trunk with the slate template).

comment:3 by chrisclaydon, 13 years ago

Using the Fusion code from the fusion2-mg21 branch, I loaded up the slate template, zoomed into the Sheboygan Parcels layer, and selected a parcel. The selection overlay showed up with an opaque background that hid all the map data underneath. I tested with a real version of IE6 (6.0.2900.2180.xpsp_sp2_rtm.040803-2158) in a VM. It could be that IETester does not emulate the PNG transparency issues present in IE6.

comment:4 by chrisclaydon, 13 years ago

I just downloaded IETester, and I can reproduce the problem with it too. Which operating system are you using, Mike? I have XP.

comment:5 by chrisclaydon, 13 years ago

Also which version of MapGuide? I wonder if your deployment is reverting to the old selection mechanism (using GetMapImage)...

comment:6 by madair, 13 years ago

I'm using XP and MapGuide OS 2.0.2 so that is likely the problem. I'm not able to test with a newer MapGuide since my trial license for MG2010 ran out weeks ago.

comment:7 by madair, 13 years ago

just re-reading RFC38 and found this:

We will rely on gd to perform the colorspace transformation for PNG8. Due to a limitation in gd, selection color transparency color will not be maintained. This means a PNG8 selection image will completely block out the features and labels underneath it.

Is this part of the issue?

comment:8 by tomfukushima, 13 years ago

Mike, I think that a simple check using Fiddler could tell you that the image coming back is PNG24.

On another note, why does it take so much work to get this reproduced? Something like this should be simple to diagnose. It just seems silly to me.

comment:9 by madair, 13 years ago

(In [1809]) re #220: set alpha option on MG layers for PNG transparency in IE6

comment:10 by madair, 13 years ago

Resolution: fixed
Status: assignedclosed

(In [1810]) closes #220: patch applied to 1.1 branch

comment:11 by madair, 13 years ago

As noted above, the issue was having an instance of MG to test against. MG2010 was restored and fix applied

Note: See TracTickets for help on using tickets.