Ticket #1530 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

JPG rasterfile fails to load

Reported by: goggi Owned by: ersts
Priority: major: does not work as expected Milestone:
Component: Rasters Version: 1.0.0
Keywords: Raster jpg load fails Cc: warmerdam
Platform Version: 1.0.0-kore Platform: Windows
Must Fix for Release: No Awaiting user input: no

Description

Iam trying to load raster file. JPG format. Proplem is that it only renders part of the file right. See attached image for screen shot. I can open those files in another programs so the file should not be damaged. Those files did work in preview 2 version. I can't send one of the files sadly since that is contract violation.

and if system info is of any help Windows XP SP3 Graphic: NVidia Geforce 8500 GT Drive 181.22 CPU: Intel Quad core Q6600

Attachments

QGisScreenshot.JPG Download (68.5 KB) - added by goggi 5 years ago.

Change History

Changed 5 years ago by goggi

follow-up: ↓ 2   Changed 5 years ago by dthonon

I have the same problem. To reproduce it : - create any JPEG image, for example using gimp fill with a texture. I tried 1000*1000, 5000*5000 and 10000*10000 and none worked correctly - add it as raster to QGIS - only the top part is displayed - pyramids are also truncated to the top part.

The same raster work fine with 1.0 Preview II

Platform : Windows, using the  http://trac.osgeo.org/osgeo4w/ download.

in reply to: ↑ 1   Changed 5 years ago by ersts

  • owner changed from nobody to ersts
  • status changed from new to assigned

Replying to dthonon:

I have the same problem. To reproduce it : - create any JPEG image, for example using gimp fill with a texture. I tried 1000*1000, 5000*5000 and 10000*10000 and none worked correctly - add it as raster to QGIS - only the top part is displayed - pyramids are also truncated to the top part.

I am actually having a problem reproducing this, but we have seen similar behavior in the past. Can anyone post a link to an image that is causing this behavior so we can be working with the same data?

dthonon: Can you explain how you created your pyramids? Are they internal? A while ago I removed the ability for QGIS to build pyramids internally for JPEGs because it often ended in data corruption that looked like the screenshot above (but the corrupted image was also red).

  Changed 5 years ago by goggi

Is this not just bug in the setup from osgeo4w? We are both using that, preview 2 was just normal windows installer. Some DLL (old or too new version) or some settings that is going wrong in the install.

  Changed 5 years ago by ersts

Kind of. It is going to end up being a GDAL issue in the OSGeo4W dist as nothing changed in the raster code between the preview and the version 1. Still we would like to find out what the problem is and maybe let GDAL folks know, or the builders depending on what the problem turns out to actually be.

  Changed 5 years ago by Goggi

One intresting fact. I was playing with and learning on some of the GDAL tools. I tryed to convert one of the jpg files to tiff. I get error: Corrupt JPEG data: premature end of data segment. So there is something wrong with the jpg file.

I opened the file in just paint in windows. Saved the file again with out doing anything. Then it works 100% in GDAL and Qgis. Boring thing is that I have 66 of those but I live :)

  Changed 5 years ago by Goggi

ok, sorry about this but. No I am wrong, it dont work to open in paint then save again. (Worked for one file then never again) But I downloaded GDALWIN 1.6 from GDAL home page. Running there gdal_translate works. But if I use the version that came with OSGeo4W dont. So there has to be something wrong with GDAL setup like it is in the OSGeo$W version.

Sorry about two comments same evening but I realy hate not beeing able to use version 1.0.0 and always using preview :)

  Changed 5 years ago by ersts

Can you provide an example image that does not load properly?

jpegs seem to be loading on my OSGeo4W install just fine. If your jpeg loads fine for me then I can figure start to diagnose which extra lib needs to be installed/reinstalled.

  Changed 5 years ago by warmerdam

  • cc warmerdam added

  Changed 5 years ago by warmerdam

I have confirmed this is a GDAL problem - migrating the issue to:

 http://trac.osgeo.org/gdal/ticket/2845

  Changed 5 years ago by ersts

  • status changed from assigned to closed
  • resolution set to fixed

Thanks Frank! I can confirm the updates work with your test image.

Folks having the problem: This should now be resolved. Please update your version of OSGeo4W by running setup again.

  Changed 5 years ago by anonymous

  • milestone Version 1.0.2 deleted

Milestone Version 1.0.2 deleted

Note: See TracTickets for help on using tickets.