Opened 12 years ago

Closed 12 years ago

#61 closed defect (fixed)

Symbolization: New symbolization sample data cause 500 server errors and mapagent.exe crashes

Reported by: jbirch Owned by: waltweltonlair
Priority: medium Milestone:
Component: Server Version: 1.2.0
Severity: major Keywords:
Cc: External ID: 927876

Description

Using the "Preview Geometric Properties" option in the schemareport utilities to view the resource Library://Samples/Sheboygan/Symbolization/Data/Points.FeatureSource causes a 500 server error and an entry appears in the server error log (attached) indicating

Error: XML Indexer: Parse error in document at line, 34, char 12. Parser message: Not enough elements to match content model : '((LineStyle,Thickness,Color,Unit,SizeContext),!ExtendedData1)'

Also, when trying to preview the sample layers LabeledImage and Squares in Studio, I receive a Windows "Runtime Error" message from mapagent.exe.

This is using a clean install of MapGuide 1.2.0-beta1, Apache/PHP bundled install, Windows XP Pro, SP2.

J

Attachments (1)

Error.log (3.5 KB) - added by jbirch 12 years ago.
Server error log

Download all attachments as: .zip

Change History (15)

Changed 12 years ago by jbirch

Attachment: Error.log added

Server error log

comment:3 Changed 12 years ago by waltweltonlair

The schema report big was fixed earlier today.

I believe the symbolization sample will be updated soon.

comment:4 Changed 12 years ago by rexszeto

External ID: 927876

comment:5 Changed 12 years ago by waltweltonlair

Jason - were you using DWF or AJAX when previewing the sample symbolization layers?

comment:6 Changed 12 years ago by jbirch

AJAX. Don't have DWF viewer on this machine. Can download and test if you'd like?

comment:7 Changed 12 years ago by waltweltonlair

I can't reproduce this in the current code using ASP.NET. Maybe it's a Beta1 issue?

comment:8 Changed 12 years ago by jbirch

Or maybe a PHP / SWIG issue :)

I'll re-test on beta2.

comment:9 Changed 12 years ago by waltweltonlair

Summary: New symbolization sample data cause 500 server errors and mapagent.exe crashesSymbolization: New symbolization sample data cause 500 server errors and mapagent.exe crashes

Prefixing summary with "Symbolization"

comment:10 Changed 12 years ago by waltweltonlair

Component: GeneralServer

comment:11 Changed 12 years ago by jbirch

I'm still getting errors on my home PC with the new samples.

The highways sample caused server errors (something about being unable to symbolize).

The boxes sample would view OK in the WebLayout? (from Studio 2007) but viewing the Layer preview caused MapAgent?.exe to crash.

Unfortunately, I didn't have internet access at the time. I'll try reproducing again from work, or hopefully from home if I have connectivity.

comment:12 Changed 12 years ago by jbirch

Here's the error that interstate caused:

<2007-05-27T00:53:05> Administrator

Error: Failed to stylize layer: interstate

An unclassified exception occurred.

StackTrace:

MgStylizationUtil.StylizeLayers line 923 file c:\build_bond_area\mapguide_open_source_v1.2\build_13.7\mgdev\server\src\services\mapping\StylizationUtil.cpp Failed to stylize layer: interstate

An unclassified exception occurred.

comment:13 Changed 12 years ago by waltweltonlair

Owner: set to waltweltonlair
Status: newassigned

comment:14 Changed 12 years ago by waltweltonlair

Resolution: fixed
Status: assignedclosed

This was fixed in MapGuide 1.2 with submission r1962, and in MapGuide 2.0 with submission r1963.

Note: See TracTickets for help on using tickets.