Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#315 closed defect (fixed)

AGG: Rendering glitch and error

Reported by: jbirch Owned by: traianstanev
Priority: medium Milestone: 2.0
Component: Rendering Service Version: 2.0.0
Severity: major Keywords: AGG, zinger
Cc: External ID: 1012393

Description

I'm seeing some interesting glitches (see attached image for example) with the new AGG renderer in 2.0. I've tested the same map with GD turned on, and am not seeing the same.

I am not 100% sure if this is related, but it is accompanied by the following error messages in the logs (which don't show up with GD turned on).

<2007-11-19T15:33:34> 			Administrator
 Error: Failed to stylize layer: RoadBuffer
        An unclassified exception occurred.
 StackTrace:
  - MgMappingUtil.StylizeLayers line 759 file d:\buildforgeprojects\mapguide_open_source_v2.0\build_10.7\mgdev\server\src\services\mapping\MappingUtil.cpp	Failed to stylize layer: RoadBuffer
An unclassified exception occurred.

Attachments (1)

mgos_2_0_zinger.png (21.2 KB) - added by jbirch 11 years ago.
Display bug

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by jbirch

Attachment: mgos_2_0_zinger.png added

Display bug

comment:1 Changed 11 years ago by jbirch

I can provide a package of this data offline if required.

comment:2 Changed 11 years ago by traianstanev

Owner: set to traianstanev

comment:3 Changed 11 years ago by traianstanev

Are you using a tiled map? Or perhaps a Fusion map that has a preview window? Yes, please provide the layer source so that I can try to reproduce.

comment:4 Changed 11 years ago by jbirch

No, it's just a really ugly layer (the roads).

I basically had to break my road fill polygon up into a grid; I think it was 500m*500m (but not sure) because when the whole road network was a single polygon MapGuide 1.x got really really confused - can't blame it... I'm not actually sure why I had to do this instead of a really thick line... maybe because I wanted borders on the line or something, or because the width was attribute based? Can't remember.

I'll forward you the email I sent Tom with the location of my datasets...

comment:5 Changed 11 years ago by tomfukushima

External ID: 1012393

comment:6 Changed 11 years ago by traianstanev

Resolution: fixed
Status: newclosed

comment:7 Changed 11 years ago by tomfukushima

Milestone: 2.0
Version: 2.0.0
Note: See TracTickets for help on using tickets.