Opened 11 years ago

Closed 5 years ago

#316 closed enhancement (duplicate)

Exposing Filter property of MgLayer object in .NET API

Reported by: MaksimS Owned by:
Priority: low Milestone:
Component: Web API Version:
Severity: major Keywords:
Cc: External ID:

Description

Managed MgLayer? object currently has FeatureSourceId? and FeatureClassName? properties exposed. MgLayer? properties should also include Filter property for filtering data based on layer's feature source class properties.

It's somehow logical since MgLayer? has all VectorLayerDefinition? top-level elements values exposed, except for the Filter one:

<LayerDefinition xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="LayerDefinition-1.1.0.xsd" version="1.1.0">
 <VectorLayerDefinition>
  <ResourceId>Library://MyLibrary/MyData/MsSqlServer.FeatureSource</ResourceId>
  <FeatureName>MySchema:MyClass</FeatureName>
  <FeatureNameType>FeatureClass</FeatureNameType>
  <Filter>MyValue=1</Filter>
  ...

Change History (3)

comment:1 Changed 11 years ago by MaksimS

Priority: mediumlow
Type: defectenhancement
Version: 2.0.01.2.0

comment:2 Changed 9 years ago by jbirch

Version: 1.2.0

Removing version.

comment:3 Changed 5 years ago by jng

Resolution: duplicate
Status: newclosed

Duplicate of #1154

Note: See TracTickets for help on using tickets.