Opened 11 years ago

Closed 10 years ago

#289 closed defect (fixed)

When a layer filter fails layer should be rendered empty

Reported by: zspitzer Owned by:
Priority: high Milestone: 2.1
Component: Resource Service Version: 1.2.0
Severity: major Keywords:
Cc: External ID:

Description

currently when a layer filter fails, mapguide renders the layer without any filter see ticket:254

Change History (5)

comment:1 Changed 11 years ago by zspitzer

Priority: mediumhigh

I think in terms of mapguide being developer friendly this is *really* important.

A use-case like a contractor assignment application where the contractor logs in and is meant to see their assigned jobs on the map (via a filter) can lead to some fairly serious business problems, lost time, two contractors turning up to the same job etc.

Any mapguide application which has completely separate customer business's cannot currently be guaranteed that their data is private.

I hit this error because the King.Oracle driver fails a lot with layer filters, but beyond monitoring SQL on the database there is no feedback, beyond maybe seeing too much data.

As an out of the box experience for someone evaluating mapguide, i would find this very frustrating and I did waste hours of time because of this myself

comment:2 Changed 11 years ago by jbirch

Milestone: 2.0

Setting milestone to 2.0. Not a promise, just an indication of my support.

comment:3 Changed 10 years ago by tomfukushima

Milestone: 2.0

comment:4 Changed 10 years ago by tomfukushima

This is as designed, but as I can see it is undesirable. Whoever does this, please change the behavior so that if the filter fails, the layer doesn't render and an entry is put into the error log. Tom

comment:5 Changed 10 years ago by ronnielouie

Milestone: 2.1
Resolution: fixed
Status: newclosed

Changed behaviour so that layer will not render when the filter fails. Instead an exception is thrown and written to log.

http://trac.osgeo.org/mapguide/changeset/3152

Note: See TracTickets for help on using tickets.