Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#141 closed defect (fixed)

Cannot find overload for MgMappingService::GeneratePlot()

Reported by: ronnielouie Owned by: anonymous
Priority: medium Milestone: 1.2
Component: Mapping Service Version: 1.2.0
Severity: major Keywords:
Cc: External ID: 929288

Description

The overloaded GeneratePlot?() which takes MgCoordinate? object as the second argument can not be found when the actual object is a derived type from MgCoordinate?. Actual error result is: Arguments passed did not match any overload for method _wrap_MgMappingService_GeneratePlot.

Change History (5)

comment:1 Changed 12 years ago by anonymous

Owner: changed from ronnielouie to anonymous
Status: newassigned

comment:2 Changed 12 years ago by anonymous

Resolution: fixed
Status: assignedclosed

Modify SWIG to code generation to also look at the parent class of the derived object. Fixed by submission http://trac.osgeo.org/mapguide/changeset/1727 Fixed by submission http://trac.osgeo.org/mapguide/changeset/1729

comment:3 Changed 12 years ago by jbirch

Is this a duplicate of #123 ?

comment:4 Changed 12 years ago by jbirch

And is it possible that this fixes Jim's problem: #143 ?

comment:5 in reply to:  4 Changed 12 years ago by anonymous

Replying to jbirch:

And is it possible that this fixes Jim's problem: #143 ?

Yes. I just took a look through the code and the modifications to the SWIG generated wrapper code also affects the MgCoordinateSystemTransform::Transform() method which called is from MgPoint::Transform().

Note: See TracTickets for help on using tickets.