Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#22 closed defect (fixed)

grass-core form Ubuntugis (Precise) depends on libgdal1-1.7.0

Reported by: leohardtke Owned by: jlarouche
Component: General Severity: grave
Keywords: Cc:

Description

The Grass (6.4.2) package from ubuntugis, depends on libgdal1-1.7.0 (oficial package); should it not however depends on libgdal1 (1.9) from de ppa?. I think it is making a mess on my Precise box!

Thanks and sorry for the noise if I'm not right!

Change History (8)

comment:1 Changed 10 years ago by jlarouche

Owner: changed from ubuntu@… to jlarouche
Status: newassigned

You're right, I can confirm that it's still using libgdal1-1.7.0.

I'm working on it

comment:2 Changed 10 years ago by leohardtke

Hi, good to hear someone is working on it... I just want to let you know, the same is happening with the qgis-nigthly package for ubuntugis ppa.

http://hub.qgis.org/issues/5607 http://hub.qgis.org/issues/5564

hope it helps Leonardo

comment:3 Changed 10 years ago by leohardtke

may I ask wich package contains gdal-config in the ppa? Is there a libgdal-dev package? because I only found gdal-config on the 1.7.3 version of libgdal-dev from universe

Leonardo

comment:4 in reply to:  3 Changed 10 years ago by leohardtke

Replying to leohardtke:

may I ask wich package contains gdal-config in the ppa? Is there a libgdal-dev package? because I only found gdal-config on the 1.7.3 version of libgdal-dev from universe

Leonardo

Replaying myself! I found the packages in https://launchpad.net/~ubuntugis/+archive/ubuntugis-unstable/+files/libgdal-dev_1.9.0-2%7Eprecise1_amd64.deb

but not in synaptic.... that is really strange! is'n it?

comment:5 Changed 10 years ago by aboudreault

gdal-config is in libgdal1-dev (for gdal <=1.8) and libgdal-dev (for gdal >=1.9). Not sure what's wrong with synaptic... but you should see the dev package with:

 apt-cache search gdal

comment:6 in reply to:  5 Changed 10 years ago by leohardtke

Replying to aboudreault:

gdal-config is in libgdal1-dev (for gdal <=1.8) and libgdal-dev (for gdal >=1.9). Not sure what's wrong with synaptic... but you should see the dev package with:

 apt-cache search gdal

ok! thaks! found it!

comment:7 Changed 10 years ago by jlarouche

Resolution: fixed
Status: assignedclosed

Grass package has been updated, it now uses libgdal1 version 1.9.0-2~precise1.

I hope it'll clear the mess in your box!

comment:8 Changed 10 years ago by leohardtke

Yes! Thaks! Now everything is working perfect!

Actually my problem (mess!!!) was I did not notice the existence of lbgdal and libdal1!!! But it served to correct both, the grass and qgis packages, thanks to your effort and Jürgen Fischer!

Note: See TracTickets for help on using tickets.