Opened 10 years ago

Closed 5 years ago

#21 closed defect (invalid)

MrSID won't compile with UbuntuGIS GDAL 1.9 - libgeotiff issue

Reported by: gfleming Owned by: ubuntu@…
Component: General Severity: serious
Keywords: Cc: warmerdam

Description (last modified by warmerdam)

I've just upgraded to gdal 1.9 (UbuntuGIS) on Ubuntu 11.10. When I tried to compile MrSID support (which was working fine in 1.8) I get this:

checking for XTIFFClientOpen in -lgeotiff... no configure: error: libgeotiff is required to build GDAL MrSID driver

with both these MrSID versions:

gdal-mrsid-build /usr/local/MrSID_DSDK-8.5.0.3422-linux.x86-64.gcc44/Raster_DSDK/ (for this I also had to disable jp2mrsid in the gdal-mrsid-build script)

and

gdal-mrsid-build /usr/local/Geo_DSDK-7.0.0.2167/

I have libgeotiff 1.3 and 1.2.5 installed.

I brought this up on the gdal-dev list and Even Roualt said:

this should be something to report to the ubuntugis team. This build script isn't maintained by the GDAL project itself. Looking at the symbols needed by libltidsdk.so from the 8.0.0 SDK, there's no reason from requiring libgeotiff to build the MrSID SDK. I'm wondering if this error doesn't come from the fact that GDAL 1.9.0 in ubuntugis is now built with versionned symbols now.

Change History (2)

comment:1 by warmerdam, 10 years ago

Cc: warmerdam added
Description: modified (diff)

comment:2 by Bas Couwenberg, 5 years ago

Resolution: invalid
Status: newclosed

Apparently nobody handles Trac tickets any more, closing this ancient issue.

Note: See TracTickets for help on using tickets.