Opened 16 years ago

Closed 16 years ago

Last modified 15 years ago

#872 closed bug (fixed)

Error in C++ plugin templates files

Reported by: fpacheco Owned by: homann
Priority: major: does not work as expected Milestone:
Component: C++ Plugins Version: Trunk
Keywords: C++ plugins Cc:
Must Fix for Release: No Platform: All
Platform Version: Awaiting user input: no

Description

I believe that there is an error in the archives plugin.cpp and plugin.h in the src/plugins/plugin_template directory. That error makes the menu QGis act in odd ways. The problem is that the source code doesn't use the interface to create the toolbar.

Steps to reproduce the error: 1 - create a plugin in C++ with the python script (plugin_builder.py); 2 - compile the plugin; 3 - load the plugin in QGis; 4 - close QGis; 5 - run QGis -> The application menu acts abnormally. Thanks. Fernando.

Attachments (1)

patch.tar.gz (764 bytes ) - added by fpacheco 16 years ago.

Download all attachments as: .zip

Change History (5)

by fpacheco, 16 years ago

Attachment: patch.tar.gz added

comment:1 by homann, 16 years ago

Owner: changed from nobody to homann
Status: newassigned

comment:2 by homann, 16 years ago

This applies also to eVis, thanks for finding it! I have submitted ticket to eVis

comment:3 by homann, 16 years ago

Resolution: fixed
Status: assignedclosed

Fixed in r7796, together with some translation fixes.

comment:4 by (none), 15 years ago

Milestone: Version 0.9.2

Milestone Version 0.9.2 deleted

Note: See TracTickets for help on using tickets.