Opened 17 years ago

Closed 17 years ago

Last modified 15 years ago

#637 closed defect (fixed)

QGIS Crash when WMS getcap fails

Reported by: spatialguru@… Owned by: nobody
Priority: major: does not work as expected Milestone:
Component: WMS Version: Trunk
Keywords: Cc:
Must Fix for Release: No Platform: OS X
Platform Version: 10.4.8 (intel) Awaiting user input: no


  • I've built qgis_unstable from source
  • I "add default services" for WMS
  • Selected server connection "DM Solutions GMAP" and press "connect"
  • Message pops up saying: Could not understand the response. The wms provider said: WMS Server responded unexpectedly with HTTP Status Code 502 (Proxy Error) Tried URL:
  • I press "close" then QGIS crashes

Let me know if there are more tests I can do. Same action with Lizardtech connection. JPL ones seem to work fine. Dump report from apple tool is attached. Tyler

Attachments (1)

qgis_wms_crash.txt (24.5 KB ) - added by spatialguru@… 17 years ago.
dump report of wms crash

Download all attachments as: .zip

Change History (5)

by spatialguru@…, 17 years ago

Attachment: qgis_wms_crash.txt added

dump report of wms crash

comment:1 by homann, 17 years ago

Did you specify a proxy host?

comment:2 by spatialguru@…, 17 years ago

No, I left proxy host empty as I do not use one. It is the same as the other entries that work.

comment:3 by anonymous, 17 years ago

Resolution: fixed
Status: newclosed

Confirmed, homann's fix worked for me. Thanks.

comment:4 by (none), 15 years ago

Milestone: Version 0.9

Milestone Version 0.9 deleted

Note: See TracTickets for help on using tickets.