Opened 17 years ago

Closed 16 years ago

Last modified 15 years ago

#632 closed bug (fixed)

various problems using WMS with QGIS

Reported by: marco.lechner@… Owned by: homann
Priority: major: does not work as expected Milestone:
Component: WMS Version: 0.8
Keywords: WMS postgis Cc:
Must Fix for Release: Yes Platform: Debian
Platform Version: Win32 & opensuse Awaiting user input: no


Hi list,

I'm having a few problems with my WMS service using QGIS as client. May be anyone has a few hints or ideas:

Using QGIS 0.8.0 on opensuse:

  • a polygon layer doesn't show with transparency - even though it is

implemented in the WMS and it works with other clients, the transparency as well is not adjustable using the properties menu (well i can change it to 50% but it dioesn't change the view) - the transparency works very nice, if I use the WMS-feeding postgis-service directly. [projection on runtime is activated]

Using QGIS0.8.1preview2 (pretty fresh installation with complete uninstall of 0.8.1p1) on WinXP:

  • while zooming in a WMS-raster or vektor layer an error message appears:

msWMSLoadGetMapParams(): WMS server error. Image size out of range, WIDTH and HEIGHT must be between 1 and 2048 pixels.

This is probably due to a bug in the QGIS program. Please report this error.

Tried URL:,12.675728,80.602583,12.866004&SRS=EPSG:4326&WIDTH=3962&HEIGHT=3962&LAYERS=1.0.1%20Results%20Group%20Discussions&STYLES=&FORMAT=image/png&TRANSPARENT=TRUE

  • get FeatureInfo doesn't return any results using the WMS (works, if I

use the WMS-feeding postgis-service directly)

  • projection on runtime is activated, but layers show up at different

places while loading the same layer via WMS and the WMS-feeding postgis-service (the wms layer is displaced, it works using QGIS 0.8.0 on opensuse)

Any ideas, hints, solutions, explanations?


Change History (8)

comment:1 by homann, 17 years ago

Awaiting user input: unset
Milestone: Version 0.8.1Version 0.8.2
Owner: changed from nobody to homann
Status: newassigned

So, there are three issues: 1) Transparency doesn't seem to work. 2) Zooming doesn't work 3) Get featuerinfo does not work.

Am I right in this?

Can you split this bug in three parts, perhaps? It's easier to keep track on what is fixed and what is not. We work in small increments. :-)

comment:2 by anonymous, 17 years ago

I have (tried to) fix issue 2 (maybe wrong placement too?) in r6754. Please download source, compile and see if it gets better. Many thanks for your help.

If you have svn, you can check out with

svn co qgis_08

and build with cmake.

comment:3 by homann, 17 years ago

Above comment was me, and the *correct* svn path is

svn co qgis_08

'branches' not 'tags'

comment:4 by homann, 17 years ago

Awaiting user input: set

Regarding 1), transparency is not supported for WMS at the moment

comment:5 by homann, 17 years ago

Version: HEAD0.8

comment:6 by homann, 17 years ago

Component: Build/InstallWMS

Uninstall old versionj and install this and try. Most problems should be fixed.

comment:7 by homann, 16 years ago

Awaiting user input: unset
Resolution: fixed
Status: assignedclosed

Please let me know if there are any unsolved issues.

comment:8 by (none), 15 years ago

Milestone: Version 0.9.2

Milestone Version 0.9.2 deleted

Note: See TracTickets for help on using tickets.