Opened 17 years ago

Closed 16 years ago

Last modified 14 years ago

#522 closed defect (duplicate)

Major shapefile display error

Reported by: kwilliams@… Owned by: nobody
Priority: major: does not work as expected Milestone:
Component: Vectors Version: 0.8
Keywords: Cc:
Must Fix for Release: No Platform: Windows
Platform Version: Awaiting user input: no


I have two shapefiles for the entire State of Maine that display either badly or completely wrong in QGIS. Both were made by dissolving (Using ArcCatalog/ArcToolbox) all of the townships in the State so that only the shape of the State is present. Due to many islands, there are over 1,000 polygon features.

In QGIS, the 1:100k shapefile displays as half fill, half black (see attached screenshot qgis_error1.png). The 1:24k scale, higher detail shapefile is really bad, missing the vast majority of the state (see qgis_error2.png showing the same extent).

This is a major problem. I remember 0.7.4 on OS X (but not Windows) having similar difficulty where it simply ran into a maximum number of vertices limit. Does this limit still exist, now in Windows too?

I have tried using multipart polygon features with the exact same results.

Attachments (3)

qgis_error1.png (68.9 KB ) - added by anonymous 17 years ago.
qgis_error2.png (66.9 KB ) - added by kwilliams@… 17 years ago.
wrong_rendering.png (3.0 KB ) - added by anonymous 17 years ago.
Wrong method to draw a polygon with holes

Download all attachments as: .zip

Change History (11)

by anonymous, 17 years ago

Attachment: qgis_error1.png added

by kwilliams@…, 17 years ago

Attachment: qgis_error2.png added

comment:1 by kwilliams@…, 17 years ago

Version: HEAD0.8

I tried simplifying the shapefile using ArcToolbox and it appears that there is a limit to the number of allowable vertices per feature. The simplified shapefile (simplified from the dissolved shapefile) displays just fine. Unfortunately, the reduced detail severely hampers the shapefile's usefulness and appearance when zoomed in.

comment:2 by anonymous, 17 years ago

Milestone: Version 0.8 Release

comment:3 by g_j_m, 17 years ago

This is most likely a problem with the filling of complex polygons in Qt's drawing algorithms. We have no complete solution to this, and are awaiting a fix for Qt. Further details are in ticket #83.

There are two controls in the Settings:Options:Rendering dialog box that may help. Try 'Make lines appear less jagged...', and 'Fix problems with incorrectly filled polygons'. In many cases one of these two options will fix problems with incorrectly filled polygons.

comment:4 by anonymous, 17 years ago

I have also observed this behaviour.

Are you trying to draw a polygon with holes by inserting extra segments from the outer boundary to the holes?

This works, provided the extra edges don't cut through any other edge. If they do, the result usually looks like the attached examples.

See attached file wrong_rendering.png


by anonymous, 17 years ago

Attachment: wrong_rendering.png added

Wrong method to draw a polygon with holes

comment:5 by guy.duplaa@…, 17 years ago

I also have a wrong display with one huge object with islands which is always black like in one of the attached files. It is like if the outside black border was coming inside, so the object looks like filled black. You can verify by changing the default black colour to another one.

For this object, i change in the layer properties the line value which is by default continue by another one and it looks fine. Hope it helps

comment:6 by timlinux, 17 years ago

Milestone: Version 0.8.2 Release

comment:7 by g_j_m, 16 years ago

Awaiting user input: unset
Resolution: duplicate
Status: newclosed

This is the same problem as is discussed in ticket #83.

comment:8 by (none), 14 years ago

Milestone: Version 0.9.1

Milestone Version 0.9.1 deleted

Note: See TracTickets for help on using tickets.