Opened 9 years ago

Closed 9 years ago

#3221 closed enhancement (duplicate)

Fast, easy and beautiful on the fly rule-based rendering of OSM maps

Reported by: mayeulk Owned by: nobody
Priority: major: does not work as expected Milestone: Version 1.7.0
Component: Symbology Version:
Keywords: Cc:
Must Fix for Release: No Platform: All
Platform Version: Awaiting user input: no

Description

Currently, rule-based rendering of openstreetmap.org-based maps is pretty slow, not easy to achieve (many data-management operation, need to apply patch manually and recompile...) and sometimes give ugly results. It should be fast, easy and beautiful.

Fast: to make navigation a fun experience; to allow doing this on old computers/computers without internet access (for users not having access to the slippy map). Easy: because everybody can create new tags of tags, there are thousands of different tags. They will never be displayed all on online-rendered map. There are as many different needs as users. Each user should be able to define what he/she wants to render, and how, based on personal needs and tastes. Beautiful: artefacts, unwanted graphic features and semantic needs that are impossible to meet make ugly maps; a beautiful map is easy to read for the ordinary user, rich and precise for the advanced user.

Below are links to related discussion and tickets related to achieving this more global need. ticket:3039 ticket:2832

Change History (1)

comment:1 Changed 9 years ago by jef

Resolution: duplicate
Status: newclosed

duplicate of #3222

Note: See TracTickets for help on using tickets.