Opened 14 years ago

Closed 13 years ago

#1600 closed bug (fixed)

georeferencer fails with Critical error

Reported by: steko Owned by: nobody
Priority: major: does not work as expected Milestone: Version 1.2.0
Component: C++ Plugins Version: Trunk
Keywords: georeferencer Cc: pcav
Must Fix for Release: Yes Platform: Debian
Platform Version: Awaiting user input: no

Description

I am trying to georeference a scanned map in TIFF format with linear method, but the Georeferencer plugin fails to generate the .wld file, giving the following error (I ran qgis from the command line):

Critical: QgsCoordinateReferenceSystem::createFromWkt -- theWkt is uninitialised, operation failed

This happens both in an empty project (no reprojection defined) and an existing one (with some layers and a custom CRS).

Change History (6)

comment:1 by lutra, 13 years ago

Cc: pcav added

Is this still true?

I'm not able to reproduce it with qgis 1.2 from trunk under ubuntu 9.04.

Please give it a try again and report back.

comment:2 by steko, 13 years ago

yes, it is still true (the message about theWkt still shows in the terminal), even though I can't test it now with real-world data. Since the first bug report I switched happily to helmert and polynomial methods with good results, but I think the default method should work.

Also, apparently there's no way to know that georectification has failed if not using a terminal, which is somehow rare I'm afraid.

comment:3 by lutra, 13 years ago

Resolution: fixed
Status: newclosed

comment:4 by lutra, 13 years ago

Resolution: fixed
Status: closedreopened

comment:5 by lutra, 13 years ago

ok now I see. Nevertheless the referencing seems ok to me: it produces the world file and the raster goes in the right place. Did you find any evidence that it doesn't works as supposed?

comment:6 by steko, 13 years ago

Resolution: fixed
Status: reopenedclosed

as I said before right now I've no real-world data to test with. Honestly, I can't remember the exact problem I had 4 months ago (I was finishing my MA dissertation!), so if you see the very same messages as I do and it works, feel free to close this bug.

cheers, steko

Note: See TracTickets for help on using tickets.