Opened 12 years ago

Closed 11 years ago

Last modified 5 years ago

#611 closed defect (wontfix)

[raster] gdal2wktraster.py crashes on Windows 7

Reported by: pracine Owned by: pracine
Priority: low Milestone: PostGIS Fund Me
Component: raster Version: master
Keywords: Cc:

Description

This might be true for Windows Vista as well.

This is a documented GDAL for Python issue:

http://trac.osgeo.org/gdal/ticket/3456

This happen when the -k option is used. The band.ReadAsArray call makes gdal2wktraster.py to crashes.

One work around is to install the GDAL version available at:

http://vbkto.dyndns.org/sdk/

It comes with MapServer but you can just copy the GDAL binaries and GDAL for Python you need.

Change History (5)

comment:1 by pracine, 12 years ago

This little Python script is sufficient to reproduce the crash:

from osgeo import gdal import osgeo.gdalconst as gdalc ds = gdal.Open("C:/temp/srtm_01_02.tif", gdalc.GA_ReadOnly); band = ds.GetRasterBand(1) pixels = band.ReadAsArray(0, 0, 50, 50, 50, 50) x = len(pixels)

comment:2 by mloskot, 11 years ago

Pierre, I'm confused a bit about this. It is either a bug somewhere or simply you are trying GDAL not built with Python NumPy support. The raster2pgsql.py does require fully-featured Python bindings for GDAL.

Somewhat related ticket is #838

comment:3 by pracine, 11 years ago

Resolution: wontfix
Status: newclosed

Numpy was there. I entered this ticket mainly for documenting the problem. I don't think we can do anything. It seems to be dependent on how GDAL is compiled.

comment:4 by pracine, 10 years ago

Milestone: PostGIS Raster FuturePostGIS Future

comment:5 by robe, 5 years ago

Milestone: PostGIS FuturePostGIS Fund Me

Milestone renamed

Note: See TracTickets for help on using tickets.