Opened 7 months ago

Closed 7 months ago

#5536 closed defect (fixed)

Stop shipping comments with the extensions

Reported by: robe Owned by: strk
Priority: blocker Milestone: PostGIS 3.5.0
Component: build Version: master
Keywords: Cc:

Description

With this new docbook5 change, it's become painfully obvious we need to ditch our extension build dependency on comments cause it flows into our regression testing ability.

Change History (6)

comment:1 by strk, 7 months ago

I think the decision about whether or not including comments in the extension has NOT to be based on our ability to keep build bots happy, but solely on the opportunity to include them for user happiness.

Personally I'm happy with a more modular system so would welcome removing those comments and let users decide whether or not to install the comments via script, which at that point could even be localized ( ie: psql -f topology_comments_de.sql )

comment:2 by Sandro Santilli <strk@…>, 7 months ago

In 644797a9/git:

Do not check documentation on make check if deps are not met

References #5536 #5542

comment:3 by strk, 7 months ago

Right now the release tarball includes the comments, which I think was done specifically to reduce the build dependencies. If we drop comments from extension I'd also stop shipping pre-built comments.

comment:4 by Sandro Santilli <strk@…>, 7 months ago

In bfaab76/git:

Check for xml checking validation deps at configure time

References #5536 #5542

comment:5 by strk, 7 months ago

Summary: Stop shipping comments with the extension build - don't require docbook anything to regressStop shipping comments with the extensions

Just to clarify: after the recent changes ( [644797a9ea72e4db0c8768b96fe1affd97252baf/git] ) the "regress" dependency difference from 3.4 is only the need of "xmllint" which was added as a dependency to build those comments. Docbook5 xml is not needed because comments are using XSL files included in the PostGIS source tree, so only the xsltproc processor was required in 3.4 and now we added xmllint to that dependency.

For this reason I changed the ticket title to just focus on dropping the inclusion of comments from the extensions, as this is not strictly tight with regression testing.

For reference, the (passed) PSC motion to drop comments from extensions is here: https://lists.osgeo.org/pipermail/postgis-devel/2023-September/030115.html

comment:6 by Sandro Santilli <strk@…>, 7 months ago

Resolution: fixed
Status: newclosed

In 93a9e00/git:

Stop including comments in extensions

Closes #5536
Includes mention in the NEWS file

Note: See TracTickets for help on using tickets.