#5211 closed defect (duplicate)

Upgrade from unpackaged2.5--3.2.3dev fails on trying to add spgist_geometry_ops_nd opclass

Reported by: strk Owned by: pramsey
Priority: blocker Milestone: PostGIS 3.0.7
Component: postgis Version: 3.0.x
Keywords: Cc:

Description

See session:

strk@c19:/usr/local/src/postgis/postgis-3.2(stable-3.2)] regress/run_test.pl -v --extension --upgrade --upgrade-path unpackaged2.5--3.2.3dev regress/core/regress
Upgrade path: unpackaged2.5 --> 3.2.3dev
PATH is /home/postgresql/PG12/bin/:/home/strk/.nvm/versions/node/v16.16.0/bin:/home/strk/.local/bin:/home/strk/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/strk/bin:/home/strk/go/bin:/opt/bitcoin/bin:/home/strk/bin:/home/strk/go/bin:/opt/bitcoin/bin
Checking for shp2pgsql ... found
Checking for pgsql2shp ... found
TMPDIR is /tmp/pgis_reg
Creating database 'postgis_reg' 
Loading unpackaged components from /home/postgresql/PG12/share/contrib/postgis-2.5
Loading PostGIS into 'postgis_reg' 
Upgrading from postgis 2.5.8dev
Upgrading PostGIS in 'postgis_reg' using: CREATE EXTENSION postgis VERSION '3.2.3dev' FROM unpackaged;
 failed (Error encountered updating EXTENSION POSTGIS: /tmp/pgis_reg/regress_log)
-----------------------------------------------------------------------------
NOTICE:  schema "public" already exists, skipping
CREATE SCHEMA
NOTICE:  schema "public" already exists, skipping
NOTICE:  schema "public" already exists, skipping
NOTICE:  schema "public" already exists, skipping
ERROR:  Trying to add OPERATOR CLASS spgist_geometry_ops_nd USING SPGIST to postgis, got operator class "spgist_geometry_ops_nd" does not exist for access method "spgist" (42704)
CONTEXT:  PL/pgSQL function inline_code_block line 25 at RAISE
-----------------------------------------------------------------------------
Died at regress/run_test.pl line 1663.

This was introduced by commit [b8b2614feb9a3529803f5d2b6d725dcf5e2c889e/git] aimed at fixing #5209

Similar commits went in branches 3.1 ([f2c16bd63f888e285feebb8050e7c46cb6ddd091/git]) and 3.0 ([d4c55c6c5562ab286e5a78d7675c8d000913d82c/git])

Change History (1)

comment:1 by strk, 20 months ago

Resolution: duplicate
Status: newclosed

This is actually a duplicate of #5187

Note: See TracTickets for help on using tickets.