Opened 4 years ago

Closed 4 years ago

#4508 closed defect (fixed)

Regression Failures at r17812

Reported by: pramsey Owned by: Algunenano
Priority: high Milestone: PostGIS 3.0.0
Component: postgis Version: master
Keywords: Cc: Algunenano

Description

From the tests failing, I suspect the source is the repeated points / MVT work recently committed.

--- snaptogrid_expected 2019-09-03 19:53:59.000000000 -0700
+++ /tmp/pgis_reg/test_89_out   2019-09-16 15:41:16.000000000 -0700
@@ -3,5 +3,5 @@
 t
 t
 t
-POLYGON((0 0,10 0,10 10,0 10,0 0))|BOX(0 0,10 10)
-POLYGON((0 0,10 0,10 10,0 10,0 0))|BOX(0 0,10 10)
+POLYGON((0 0,10 0,10 10,0 10,0 0))|BOX(0 0,10.6000003814697 10.5)
+POLYGON((0 0,10 0,10 10,0 10,0 0))|BOX(0 0,10.6000003814697 10.5)

and

--- remove_repeated_points_expected 2019-09-03 19:53:59.000000000 -0700
+++ /tmp/pgis_reg/test_82_out   2019-09-16 15:41:15.000000000 -0700
@@ -17,4 +17,4 @@
 16|MULTIPOINT(0 0,1 1,2 2)
 17|MULTIPOINT(0 0,4 4)
 18|POLYGON((-215922 5325694,-218693 5322119,-216112 5325812,-215922 5325694))
-19|POLYGON((0 0,10 0,10 10,0 10,0 0))|BOX(0 0,10 10)
+19|POLYGON((0 0,10 0,10 10,0 10,0 0))|BOX(0 0,10.5 10.5)

and

--- measures_expected   2019-09-03 19:53:59.000000000 -0700
+++ /tmp/pgis_reg/test_57_out   2019-09-16 15:41:02.000000000 -0700
@@ -68,14 +68,14 @@
 #4278.3|f
 #4278.4|1
 NOTICE:  One or both of the geometries is missing z-value. The unknown z-value will be regarded as "any value"
-#4328.1|t|t
+ERROR:  lw_dist2d_distribute_bruteforce: Unsupported geometry type: Tin
 NOTICE:  One or both of the geometries is missing z-value. The unknown z-value will be regarded as "any value"
-#4328.2|t|t
+ERROR:  lw_dist2d_distribute_bruteforce: Unsupported geometry type: Tin
 NOTICE:  One or both of the geometries is missing z-value. The unknown z-value will be regarded as "any value"
-#4328.3|t|t
+ERROR:  lw_dist2d_distribute_bruteforce: Unsupported geometry type: Tin
 NOTICE:  One or both of the geometries is missing z-value. The unknown z-value will be regarded as "any value"
-#4328.4|t|t
+ERROR:  lw_dist2d_distribute_bruteforce: Unsupported geometry type: Tin
 NOTICE:  One or both of the geometries is missing z-value. The unknown z-value will be regarded as "any value"
-#4328.5|t|t
+ERROR:  lw_dist2d_distribute_bruteforce: Unsupported geometry type: Tin
 NOTICE:  One or both of the geometries is missing z-value. The unknown z-value will be regarded as "any value"
-#4328.6|t|t
+ERROR:  lw_dist2d_distribute_bruteforce: Unsupported geometry type: Tin

the last one looks like komzpa.

Darwin Sparrow.local 18.7.0 Darwin Kernel Version 18.7.0: Tue Aug 20 16:57:14 PDT 2019; root:xnu-4903.271.2~2/RELEASE_X86_64 x86_64

Change History (4)

comment:1 by Algunenano, 4 years ago

First and second point to the bbox not being refreshed in your environment, which is odd. I'd have expected to break the repeated points function with the speed up changes, but all I did to snap2grid was to add the refresh call and add those tests.

Also todays changes (the speed up) moved the bbox drop to liblwgeom instead of postgis, so it's even stranger.

The 3rd error looks also points to a possibly outdated liblwgeom

Can you confirm you are testing with HEAD and a clean environment, please?

comment:2 by Algunenano, 4 years ago

I couldn't reproduce this in OSX:

Darwin rs-iMac.local 18.2.0 Darwin Kernel Version 18.2.0: Thu Dec 20 20:46:53 PST 2018; root:xnu-4903.241.1~1/RELEASE_X86_64 x86_64

  GEOS config:          /usr/local/bin/geos-config
  GEOS version:         3.7.2
  GDAL config:          /usr/local/bin/gdal-config
  GDAL version:         2.4.2
  SFCGAL config:        /usr/local/bin/sfcgal-config
  SFCGAL version:       1.3.7
  PostgreSQL config:    /usr/local/bin/pg_config
  PostgreSQL version:   PostgreSQL 11.5
  PROJ4 version:        62
  Libxml2 config:       /usr/bin/xml2-config
  Libxml2 version:      2.9.4

Tests are also passing with Debian buster 32bit.

comment:3 by pramsey, 4 years ago

I think I have a bum build, I just rebuilt on a separate machine and have clean results. I think, once again, I'm seeing the effect of liblwgeom, and my 'make check' is picking up an old liblwgeom instead of the one in the build tree. I bet if I do 'make install' and then 'make check' my problems will disappear.

comment:4 by pramsey, 4 years ago

Resolution: fixed
Status: assignedclosed

Yep, confirmed. Now if only I could figure out why postgis, which is supposed to statically link against the local copy of liblwgeom instead ends up running against the copy in /usr/local/lib.

Note: See TracTickets for help on using tickets.