Opened 15 months ago

Closed 8 months ago

#4482 closed defect (worksforme)

Missing Windows dependencies

Reported by: joshuabogue Owned by: robe
Priority: medium Milestone: PostGIS 2.5.5
Component: build/upgrade/install Version: 2.5.x
Keywords: windows builds Cc:

Description

I first installed version 11.5 for postgres on Windows 10 x64 version. I installed version 2.5.2 of postgis using the stack builder option.

Next I tried creating a database and I kept getting the message 'Could not load library "C:/Program Files/PostgreSQL/11/lib/rtpostgis-2.5.dll": The specified module could not be found.'

So I spend a good part of the day trying to get the plugin to work. Different versions, computers, manual installing postgis, and a lot of other things.

I finally found using a dependency walker replacment from "https://github.com/lucasg/Dependencies" that I needed a reference to "libeay32.dll" and "ssleay32.dll" so I copied out of the postgisgui folder to the posgres bin folder and the command "CREATE EXTENSION posgis" succeded.

Change History (9)

comment:1 Changed 15 months ago by pramsey

Owner: changed from pramsey to robe

comment:2 Changed 15 months ago by pramsey

Summary: Missing dependenciesMissing Windows dependencies

comment:3 Changed 14 months ago by robe

thanks for the heads up. I'm make sure to correct in the PostGIS 2.5.3 release I am preparing.

Last edited 14 months ago by robe (previous) (diff)

comment:4 Changed 14 months ago by robe

Component: postgisbuild/upgrade/install
Keywords: wind builds added

I got another message referencing this issue. In the past EDB used to ship these libraries. It appears they changed the name of them and probably uninstalled the ones they installed. So I'll start including it in the build.

comment:5 Changed 14 months ago by robe

Keywords: windows added; wind removed

comment:6 Changed 14 months ago by robe

Milestone: PostGIS 2.5.4PostGIS 2.5.3

I've pushed out a 2.5.3 PostGIS release on stackbuilder for 64-bit PostgreSQL 9.6, 10,11 which has curl built with the new ssl libraries. That should fix the issue.

Still working on the 32-bit builds and 9.5. I'll close after I've packaged those. https://postgis.net/windows_downloads/

comment:7 Changed 13 months ago by pramsey

Milestone: PostGIS 2.5.3PostGIS 2.5.4

comment:8 Changed 8 months ago by pramsey

Milestone: PostGIS 2.5.4PostGIS 2.5.5

comment:9 Changed 8 months ago by pramsey

Resolution: worksforme
Status: newclosed

Closing after a period of time.

Note: See TracTickets for help on using tickets.