Opened 7 years ago

Closed 3 years ago

#3327 closed enhancement (wontfix)

Drop liblwgeom_internal.h use from postgis_topology module

Reported by: strk Owned by: strk
Priority: medium Milestone: PostGIS 3.0.0
Component: topology Version: master
Keywords: Cc:

Description

This is propedeutic to giving liblwgeom his own release cycles.

Internal API is currently only needed for cloning a gbox, which is something that could very well be in the public API:

postgis_topology.c:#include "liblwgeom_internal.h" /* for gbox_clone */

Change History (4)

comment:1 by robe, 6 years ago

Milestone: PostGIS 2.3.0PostGIS 2.4.0

comment:2 by robe, 5 years ago

Milestone: PostGIS 2.4.0PostGIS 2.5.0

comment:3 by komzpa, 4 years ago

Milestone: PostGIS 2.5.0PostGIS 3.0.0

comment:4 by Algunenano, 3 years ago

Resolution: wontfix
Status: newclosed

This no longer makes sense as any .h can be considered internal and won't be installed.

Note: See TracTickets for help on using tickets.