Opened 5 years ago

Closed 4 years ago

#2908 closed defect (fixed)

Cannot upgrade: cannot drop function st_summarystats(raster,integer,boolean) because other objects depend on it

Reported by: strk Owned by: strk
Priority: medium Milestone: PostGIS 2.2.0
Component: build/upgrade/install Version: trunk
Keywords: raster Cc:

Description

I cannot upgrade an extension from 2.2.0dev to 2.2.0devnext due to this:

 cannot drop function st_summarystats(raster,integer,boolean) because other objects depend on it

Change History (4)

comment:1 Changed 5 years ago by strk

These two lines are found in rtpostgis_upgrade_cleanup.sql:

-- remove TYPE summarystats
DROP FUNCTION IF EXISTS st_summarystats(raster,int, boolean);

The datatype was removed as part of #1939

comment:2 Changed 5 years ago by strk

Alright, the return datatype changed, which is the reason why the function is dropped. BUT, we should make the drop dependent on source version, driven by postgis_proc_upgrade.pl.

When a function signature changed in an way that is not compatible with "CREATE OR REPLACE FUNCTION", we should note it with a "Last Something" documenting the incompatibility.

See also #2722

comment:3 Changed 5 years ago by strk

The function signature changed with version 2.1.0 so there's no reason to drop it when going from 2.2.0dev to 2.2.0devnext

comment:4 Changed 4 years ago by strk

Resolution: fixed
Status: newclosed

I can't reproduce this anymore, so will assume fixed.

Note: See TracTickets for help on using tickets.