Opened 7 years ago

Closed 7 years ago

#2730 closed defect (duplicate)

topology uninstall with extension doesn't uninstall everything

Reported by: robe Owned by: strk
Priority: medium Milestone: PostGIS 2.1.3
Component: topology Version: 2.1.x
Keywords: Cc:

Description

I'm getting this error on winnie when she builds with make extension run:

Checking for pgsql2shp ... found
TMPDIR is /projects/postgis/tmp/2.1.3dev_pg9.2_geos3.4.2_gdal1.10.0w64
Creating database 'postgis_reg' 
Preparing db 'postgis_reg' using 'CREATE EXTENSION'
PostgreSQL 9.2.4 on x86_64-w64-mingw32, compiled by gcc.exe (GCC) 4.5.4 20111030 (prerelease) [svn/rev.180676 - mingw-w64/oz], 64-bit
  Postgis 2.1.3dev
 - r12521
 - 2014-05-09 06:46:56
  GEOS: 3.4.2-CAPI-1.8.2 r0
  PROJ: Rel. 4.8.0, 6 March 2012

Running tests

 regress/legacy_validate .. ok 
 regress/legacy_predicate .. ok 
 regress/legacy_invalid .. ok 
 regress/sqlmm .. ok 
 regress/legacy_query .. ok 
 regress/addnode .. ok 
 regress/addedge .. ok 
 regress/addface .. ok 
 regress/addface2.5d .. ok 
 regress/addtopogeometrycolumn .. ok 
 regress/polygonize .. ok 
 regress/st_addisoedge .. ok 
 regress/st_addisonode .. ok 
 regress/st_addedgemodface .. ok 
 regress/st_addedgenewfaces .. ok 
 regress/st_changeedgegeom .. ok 
 regress/st_createtopogeo .. ok 
 regress/st_getfacegeometry .. ok 
 regress/st_getfaceedges .. ok 
 regress/st_modedgeheal .. ok 
 regress/st_modedgesplit .. ok 
 regress/st_newedgeheal .. ok 
 regress/st_newedgessplit .. ok 
 regress/st_remedgenewface .. ok 
 regress/st_remedgemodface .. ok 
 regress/st_simplify .. ok 
 regress/topoelement .. ok 
 regress/topoelementarray_agg .. ok 
 regress/topogeo_addlinestring .. ok 
 regress/topogeo_addpoint .. ok 
 regress/topogeo_addpolygon .. ok 
 regress/topogeometry_type .. ok 
 regress/topojson .. ok 
 regress/topo2.5d .. ok 
 regress/totopogeom .. ok 
 regress/droptopology .. ok 
 regress/copytopology .. ok 
 regress/createtopogeom .. ok 
 regress/createtopology .. ok 
 regress/gml .. ok 
 regress/getnodebypoint .. ok 
 regress/getedgebypoint .. ok 
 regress/getfacebypoint .. ok 
 regress/getringedges .. ok 
 regress/gettopogeomelements .. ok 
 regress/layertrigger .. ok 
 regress/validatetopology .. ok 
 uninstall .. failed (Object count pre-install (4061
) != post-uninstall (4062
))

Run tests: 48
Failed: 1
make[2]: *** [check] Error 1
make[2]: Leaving directory `/projects/postgis/branches/2.1/topology/test'
make[1]: *** [check] Error 2
make[1]: Leaving directory `/projects/postgis/branches/2.1/topology'
make: *** [check] Error 1

Change History (3)

comment:1 Changed 7 years ago by strk

Can it be for the schema (#2138) ? .. I'm not sure we test schemas ..

Or, do you know of a previous revision in which the regression --with-extension passed ?

comment:2 Changed 7 years ago by robe

That's probably it since drop extension doesn't drop the schema. No can't remember. I only recently started testing with extension and for some reason can only test on winnie so debbie doesn't because of some weird PGUser not being picked up issue.

I wonder if we can explicitly add the topology schema to the create extension script. I think the issue is that since its created by the extension machinery and not part of install script, it is not considered as part of the extension. I think by the time our script is called, the topology schema is created, so we could just manually put in an ADD EXTENSION. I'll put suggestion on #2138.

comment:3 Changed 7 years ago by robe

Resolution: duplicate
Status: newclosed

actually I'm going to assume that is the case and close this one out as a dupe.

Note: See TracTickets for help on using tickets.